aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-10-09 18:37:29 -0700
committerRosen Penev <rosenp@gmail.com>2020-10-10 18:58:19 -0700
commit6c654b4d61daf61bff69235eac34626dbe521bd2 (patch)
tree02a5e1e8efb494955556d1ffdc728c8c18aaf714 /net
parent7951e29297bd707949fdf9d2fc8f0920cdf2b381 (diff)
pdns: update to 4.3.1
Remove features removed upstream. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net')
2 files changed, 10 insertions, 8 deletions
diff --git a/net/pdns/Makefile b/net/pdns/Makefile
index 60129acf3..6097addb9 100644
--- a/net/pdns/Makefile
+++ b/net/pdns/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pdns
-PKG_VERSION:=4.2.2
+PKG_VERSION:=4.3.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
-PKG_HASH:=3a1b524b9cecd1a38fdc2e71082d9f52471d22735113a890016ff48baee16b15
+PKG_HASH:=d5146c04098ee94b9377ee491ebb3fd5eb061d7b24262f4a8e1a89f2ed3fc245
PKG_MAINTAINER:=James Taylor <james@jtaylor.id.au>
PKG_LICENCE:=GPL-2.0-only
@@ -162,9 +162,7 @@ $(eval $(call DefinePdnsBackend,odbc,,unixodbc,godbc,ODBC))
$(eval $(call DefinePdnsBackend,pgsql,,libpq,gpgsql,PostgreSQL))
$(eval $(call DefinePdnsBackend,sqlite3,,libsqlite3,gsqlite3,SQLite 3))
$(eval $(call DefinePdnsBackend,ldap,,libopenldap krb5-libs,,OpenLDAP))
-$(eval $(call DefinePdnsBackend,lua,,lua liblua,,Lua))
$(eval $(call DefinePdnsBackend,lua2,,lua liblua,,Lua2))
-$(eval $(call DefinePdnsBackend,mydns,,libmysqlclient,,MyDNS))
$(eval $(call DefinePdnsBackend,pipe,,,,Pipe))
$(eval $(call DefinePdnsBackend,remote,,,,Remote))
@@ -188,6 +186,10 @@ CONFIGURE_ARGS+= \
--enable-lua-records \
$(if $(CONFIG_PACKAGE_pdns-ixfrdist),--enable-ixfrdist,)
+CONFIGURE_VARS += \
+ boost_cv_lib_program_options=yes \
+ boost_cv_lib_program_options_LIBS=-lboost_program_options
+
define Package/pdns/install
$(INSTALL_DIR) $(1)/etc/powerdns
$(INSTALL_CONF) ./files/pdns.conf-dist $(1)/etc/powerdns/pdns.conf-dist
diff --git a/net/pdns/patches/100-pdns-disable-pdns.conf-dist.patch b/net/pdns/patches/100-pdns-disable-pdns.conf-dist.patch
index bb9af15f5..2f1316e17 100644
--- a/net/pdns/patches/100-pdns-disable-pdns.conf-dist.patch
+++ b/net/pdns/patches/100-pdns-disable-pdns.conf-dist.patch
@@ -1,6 +1,6 @@
--- a/pdns/Makefile.am
+++ b/pdns/Makefile.am
-@@ -69,11 +69,9 @@
+@@ -68,11 +68,9 @@ CLEANFILES = \
backends/gsql/gsqlbackend.gcda \
backends/gsql/gsqlbackend.gcno \
backends/gsql/gsqlbackend.gcov \
@@ -13,7 +13,7 @@
sbin_PROGRAMS = pdns_server
bin_PROGRAMS = \
-@@ -113,7 +111,7 @@
+@@ -112,7 +110,7 @@ if IXFRDIST
bin_PROGRAMS += \
ixfrdist
@@ -22,12 +22,12 @@
ixfrdist.example.yml
endif
-@@ -1256,9 +1254,6 @@
+@@ -1248,9 +1246,6 @@ dnspcap2protobuf_LDADD = \
endif
endif
-pdns.conf-dist: pdns_server
-- $(AM_V_GEN)./pdns_server --no-config --config 2>/dev/null > $@
+- $(AM_V_GEN)./pdns_server --no-config --config=default 2>/dev/null > $@
-
testrunner_SOURCES = \
arguments.cc \