aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAdze1502 <jeroen.louwes@gmail.com>2014-08-14 13:58:41 +0200
committerAdze1502 <jeroen.louwes@gmail.com>2014-08-14 13:58:41 +0200
commit69a0b5814a59ec4d921725f6960e75b8a27964bb (patch)
treeaefcb03fb2ecc7338ff90e7f7204993d1e2160cb /net
parent4699cfa82156e1ea41d76832bd05f18c06e4e22d (diff)
mwan3: update to version 1.5-3
Better way of fixing the "icmp unreachable exits wrong interface" problem Signed-off-by: Jeroen Louwes <jeroen.louwes@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/mwan3/Makefile2
-rw-r--r--net/mwan3/files/etc/hotplug.d/iface/15-mwan38
2 files changed, 5 insertions, 5 deletions
diff --git a/net/mwan3/Makefile b/net/mwan3/Makefile
index 71b59e62e..9c3f064c1 100644
--- a/net/mwan3/Makefile
+++ b/net/mwan3/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mwan3
PKG_VERSION:=1.5
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_MAINTAINER:=Jeroen Louwes <jeroen.louwes@gmail.com>
PKG_LICENSE:=GPLv2
diff --git a/net/mwan3/files/etc/hotplug.d/iface/15-mwan3 b/net/mwan3/files/etc/hotplug.d/iface/15-mwan3
index d425b6c44..ab2cd745b 100644
--- a/net/mwan3/files/etc/hotplug.d/iface/15-mwan3
+++ b/net/mwan3/files/etc/hotplug.d/iface/15-mwan3
@@ -27,11 +27,11 @@ mwan3_set_general_iptables()
$IPT -A mwan3_hook -m mark --mark 0x0/0xff00 -j mwan3_connected
$IPT -A mwan3_hook -m mark --mark 0x0/0xff00 -j mwan3_rules
$IPT -A mwan3_hook -j CONNMARK --save-mark --nfmask 0xff00 --ctmask 0xff00
+ $IPT -A mwan3_hook -m mark ! --mark 0xff00/0xff00 -j mwan3_connected
fi
if ! $IPT -S mwan3_output_hook &> /dev/null; then
$IPT -N mwan3_output_hook
- $IPT -A mwan3_output_hook -p icmp -m icmp --icmp-type 3 -j MARK --set-xmark 0xff00/0xff00
fi
if ! $IPT -S PREROUTING | grep mwan3_hook &> /dev/null; then
@@ -57,11 +57,11 @@ mwan3_set_connected_iptables()
$IPT -F mwan3_connected
for connected_networks in $($IP route | awk '{print $1}' | egrep '[0-9]{1,3}(\.[0-9]{1,3}){3}'); do
- $IPT -A mwan3_connected -d $connected_networks -m mark --mark 0x0/0xff00 -j MARK --set-xmark 0xff00/0xff00
+ $IPT -A mwan3_connected -d $connected_networks -j MARK --set-xmark 0xff00/0xff00
done
- $IPT -I mwan3_connected -d 224.0.0.0/3 -m mark --mark 0x0/0xff00 -j MARK --set-xmark 0xff00/0xff00
- $IPT -I mwan3_connected -d 127.0.0.0/8 -m mark --mark 0x0/0xff00 -j MARK --set-xmark 0xff00/0xff00
+ $IPT -I mwan3_connected -d 224.0.0.0/3 -j MARK --set-xmark 0xff00/0xff00
+ $IPT -I mwan3_connected -d 127.0.0.0/8 -j MARK --set-xmark 0xff00/0xff00
fi
}