aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorErnest Moshkov <e.moshkov@gmail.com>2017-10-22 16:57:07 +0300
committerErnest Moshkov <e.moshkov@gmail.com>2017-10-22 17:08:38 +0300
commit6943f4455080f3834ef0cc22c840631c8f9d6db2 (patch)
tree2e966896bd37bd6fa5ca0cda1770ffc10aeea572 /net
parent770ca2d401143837e212fea3fd087ed8e7623998 (diff)
ddns-scripts: fix dynv6.com "unchanged" response
Maintainer: Christian Schoenebeck <christian.schoenebeck@gmail.com> Run tested: LEDE Reboot 17.01.3 r3533-d0bf257c46 Description: user.err ddns-scripts: IP update not accepted by DDNS Provider dynv6.com response "unchanged" is OK Signed-off-by: Ernest Moshkov <e.moshkov@gmail.com>
Diffstat (limited to 'net')
-rwxr-xr-xnet/ddns-scripts/Makefile2
-rw-r--r--net/ddns-scripts/files/services2
-rw-r--r--net/ddns-scripts/files/services_ipv62
3 files changed, 3 insertions, 3 deletions
diff --git a/net/ddns-scripts/Makefile b/net/ddns-scripts/Makefile
index 2d544e947..af66ba2f2 100755
--- a/net/ddns-scripts/Makefile
+++ b/net/ddns-scripts/Makefile
@@ -12,7 +12,7 @@ PKG_NAME:=ddns-scripts
PKG_VERSION:=2.7.6
# Release == build
# increase on changes of services files or tld_names.dat
-PKG_RELEASE:=18
+PKG_RELEASE:=19
PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
diff --git a/net/ddns-scripts/files/services b/net/ddns-scripts/files/services
index 1140261fe..c717370ee 100644
--- a/net/ddns-scripts/files/services
+++ b/net/ddns-scripts/files/services
@@ -103,7 +103,7 @@
"dynu.com" "http://api.dynu.com/nic/update?hostname=[DOMAIN]&myip=[IP]&username=[USERNAME]&password=[PASSWORD]"
-"dynv6.com" "http://dynv6.com/api/update?hostname=[DOMAIN]&token=[PASSWORD]&ipv4=[IP]" "updated"
+"dynv6.com" "http://dynv6.com/api/update?hostname=[DOMAIN]&token=[PASSWORD]&ipv4=[IP]" "updated|unchanged"
"easydns.com" "http://[USERNAME]:[PASSWORD]@api.cp.easydns.com/dyn/generic.php?hostname=[DOMAIN]&myip=[IP]" "NOERROR"
diff --git a/net/ddns-scripts/files/services_ipv6 b/net/ddns-scripts/files/services_ipv6
index c593aef64..3ea2974b1 100644
--- a/net/ddns-scripts/files/services_ipv6
+++ b/net/ddns-scripts/files/services_ipv6
@@ -67,7 +67,7 @@
"dynu.com" "http://api.dynu.com/nic/update?hostname=[DOMAIN]&myipv6=[IP]&username=[USERNAME]&password=[PASSWORD]"
-"dynv6.com" "http://dynv6.com/api/update?hostname=[DOMAIN]&token=[PASSWORD]&ipv6=[IP]" "updated"
+"dynv6.com" "http://dynv6.com/api/update?hostname=[DOMAIN]&token=[PASSWORD]&ipv6=[IP]" "updated|unchanged"
"goip.de" "http://www.goip.de/setip?username=[USERNAME]&password=[PASSWORD]&subdomain=[DOMAIN]&ip6=[IP]"