aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorTiago Gaspar <tiagogaspar8@gmail.com>2024-02-09 15:21:25 +0000
committerRosen Penev <rosenp@gmail.com>2024-02-10 14:54:42 -0800
commit643e3bf73a9222b460f00dcd23aa11b6ecf3e852 (patch)
treebe95a4415e48cf5c12760e97ba8dcc8ef542b587 /net
parentf58be51721fb0e2c5aa0747bce36a19deb7392dd (diff)
jool: update to 4.1.11
Update jool to 4.1.11 and remove unneeded patch. Changelog: https://github.com/NICMx/Jool/releases/tag/v4.1.11 Signed-off-by: Tiago Gaspar <tiagogaspar8@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/jool/Makefile6
-rw-r--r--net/jool/patches/000-include-csum_tcpudp_magic-header.patch26
-rw-r--r--net/jool/patches/100-fix-compilation-warning-simple-fix.patch2
3 files changed, 4 insertions, 30 deletions
diff --git a/net/jool/Makefile b/net/jool/Makefile
index 6d5069d81..fa289ebca 100644
--- a/net/jool/Makefile
+++ b/net/jool/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=jool
-PKG_VERSION:=4.1.10
+PKG_VERSION:=4.1.11
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0-only
@@ -16,8 +16,8 @@ PKG_LICENSE_FILES:=COPYING
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/NICMx/Jool.git
-PKG_SOURCE_VERSION:=47334c9124b7a2e3253fb279e6c33acb9c2b09a6
-PKG_MIRROR_HASH:=ef34f68eb911c97016180ed09e852625a3c0fe49f7d7574382a03db75c23b60e
+PKG_SOURCE_VERSION:=aed966aa4873af2d84fd445f49cf33f719539c9e
+PKG_MIRROR_HASH:=84dcd6884d849f45a3374ab25654b20cef681a3bcf0fb7f7381281f6f14c31a4
PKG_BUILD_DIR=$(KERNEL_BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
PKG_BUILD_PARALLEL:=1
diff --git a/net/jool/patches/000-include-csum_tcpudp_magic-header.patch b/net/jool/patches/000-include-csum_tcpudp_magic-header.patch
deleted file mode 100644
index 4d004b865..000000000
--- a/net/jool/patches/000-include-csum_tcpudp_magic-header.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From aa511f8856b4a437de005f23c6932948fffd8768 Mon Sep 17 00:00:00 2001
-From: Alberto Leiva Popper <ydahhrk@gmail.com>
-Date: Sat, 1 Jul 2023 09:52:09 -0600
-Subject: [PATCH] Include csum_tcpudp_magic's header
-
-Fixes build in some kernels.
-In fact, I'm not sure why I'm not getting the warning. It looks as
-though I should.
-
-Thanks to Charles Hardin for this patch.
-
-Fixes #407.
----
- src/mod/common/rfc7915/6to4.c | 1 +
- 1 file changed, 1 insertion(+)
-
---- a/src/mod/common/rfc7915/6to4.c
-+++ b/src/mod/common/rfc7915/6to4.c
-@@ -1,6 +1,7 @@
- #include "mod/common/rfc7915/6to4.h"
-
- #include <linux/inetdevice.h>
-+#include <net/ip6_checksum.h>
- #include <net/udp.h>
- #include <net/tcp.h>
-
diff --git a/net/jool/patches/100-fix-compilation-warning-simple-fix.patch b/net/jool/patches/100-fix-compilation-warning-simple-fix.patch
index dccd70f09..2b0245943 100644
--- a/net/jool/patches/100-fix-compilation-warning-simple-fix.patch
+++ b/net/jool/patches/100-fix-compilation-warning-simple-fix.patch
@@ -15,7 +15,7 @@
static int truncated(unsigned int tabs)
--- a/src/mod/common/xlator.c
+++ b/src/mod/common/xlator.c
-@@ -889,7 +889,7 @@ void xlator_put(struct xlator *jool)
+@@ -890,7 +890,7 @@ void xlator_put(struct xlator *jool)
static bool offset_equals(struct instance_entry_usr *offset,
struct jool_instance *instance)
{