aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-02-14 15:12:18 -0800
committerRosen Penev <rosenp@gmail.com>2020-02-14 15:16:35 -0800
commit63107fa8c00762cee0c5739397cb36f8c32e8e2d (patch)
treededf7ae1bcc4337207186b14786ca62dd7f422ed /net
parent8cd7528cb0aa4afa750131d9fddf690e6e56943c (diff)
spoofer: remove host build + cleanups
The host build is not used by anything. Added PKG_INSTALL for consistency between packages. Added PKG_BUILD_PARALLEL for faster compilation. Added missing protobuf/host build dependency. This was previously specified as a host dependency, which is wrong. Removed pointless std parameter. It's only useful for old G++ versions. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/spoofer/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/net/spoofer/Makefile b/net/spoofer/Makefile
index 29811a7f2..201089ed4 100644
--- a/net/spoofer/Makefile
+++ b/net/spoofer/Makefile
@@ -19,13 +19,12 @@ PKG_MAINTAINER:=Ken Keys <spoofer-info@caida.org>
PKG_LICENSE:=GPL-3.0-or-later
PKG_LICENSE_FILES:=LICENSE
-PKG_USE_MIPS16:=0
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+PKG_BUILD_DEPENDS:=protobuf/host
-include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
-$(eval $(call HostBuild))
-
define Package/spoofer
SECTION:=net
CATEGORY:=Network
@@ -54,19 +53,15 @@ CONFIGURE_ARGS += \
CONFIGURE_VARS += \
PROTOC=$(STAGING_DIR_HOSTPKG)/bin/protoc
-EXTRA_CXXFLAGS += -std=gnu++14
-
-SPOOFER_SRC=$(PKG_BUILD_DIR)
-
define Package/spoofer/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/prober/spoofer-prober $(1)/usr/bin
- $(INSTALL_BIN) $(SPOOFER_SRC)/openwrt-files/spoofer $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin//spoofer-prober $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/openwrt-files/spoofer $(1)/usr/bin
$(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) $(SPOOFER_SRC)/openwrt-files/initscript $(1)/etc/init.d/spoofer
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/openwrt-files/initscript $(1)/etc/init.d/spoofer
$(INSTALL_DIR) $(1)/usr/share/spoofer
- $(INSTALL_DATA) $(SPOOFER_SRC)/gd_bundle.crt $(1)/usr/share/spoofer
- $(INSTALL_DATA) $(SPOOFER_SRC)/openwrt-files/spoofer-lib.sh $(1)/usr/share/spoofer
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/gd_bundle.crt $(1)/usr/share/spoofer
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/openwrt-files/spoofer-lib.sh $(1)/usr/share/spoofer
endef
$(eval $(call BuildPackage,spoofer))