aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPeter Wagner <tripolar@gmx.at>2018-09-22 03:15:11 +0200
committerPeter Wagner <tripolar@gmx.at>2018-09-22 03:15:11 +0200
commit61b5d27cb985b0da41d6f4740e68bf003ed75f9e (patch)
tree4e56ad1c10e754420bbd877f0b22afc9ef3a58a0 /net
parent30898cc49d1fa9e73deb37ae82db5dc466941e1a (diff)
git: simplify install code
Signed-off-by: Peter Wagner <tripolar@gmx.at>
Diffstat (limited to 'net')
-rw-r--r--net/git/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/net/git/Makefile b/net/git/Makefile
index 0b43d1180..52779943c 100644
--- a/net/git/Makefile
+++ b/net/git/Makefile
@@ -106,14 +106,11 @@ define Build/Compile
endef
define Package/git/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/git $(1)/usr/bin
$(RM) $(PKG_INSTALL_DIR)/usr/bin/git-cvsserver
+ $(RM) $(PKG_INSTALL_DIR)/usr/bin/git-shell
+ $(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/git-* $(1)/usr/bin
$(INSTALL_DIR) $(1)/usr/lib/git-core
- ln $(1)/usr/bin/git $(1)/usr/lib/git-core/git
- ln $(1)/usr/bin/git $(1)/usr/lib/git-core/git-upload-pack
- ln $(1)/usr/bin/git-shell $(1)/usr/lib/git-core/git-shell
$(INSTALL_DIR) $(1)/usr/share/git-core/templates
( cd $(PKG_INSTALL_DIR); $(TAR) \
--exclude=usr/lib/git-core/git-http-backend \
@@ -122,13 +119,12 @@ define Package/git/install
--exclude=usr/lib/git-core/git-remote-ftps \
--exclude=usr/lib/git-core/git-remote-http \
--exclude=usr/lib/git-core/git-remote-https \
- --exclude=usr/lib/git-core/git \
- --exclude=usr/lib/git-core/git-shell \
- --exclude=usr/lib/git-core/git-upload-pack \
-cf - \
usr/lib/git-core \
usr/share/git-core/templates \
) | ( cd $(1); $(TAR) -xf - )
+ ln $(1)/usr/lib/git-core/git $(1)/usr/bin/git
+ ln $(1)/usr/lib/git-core/git-shell $(1)/usr/bin/git-shell
endef
define Package/git-http/install