aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2023-03-14 20:58:04 +0100
committerMichael Heimpold <mhei@heimpold.de>2023-03-15 07:32:29 +0100
commit5b3575eba13b8da412dce26b009ac90870f49e8d (patch)
tree98d547de1fd0b1a0bd7166fc98953d4d0369612c /net
parent15af23b011ad4248c3bb476dbbd196fce7091075 (diff)
gensio: fix build of Python binding (refs #20604)
We need the host build of swig only. And the binding uses libgensiocpp - not the plain C library, so fix the dependency. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'net')
-rw-r--r--net/gensio/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/gensio/Makefile b/net/gensio/Makefile
index 2744a2acc..f9d6ccc9d 100644
--- a/net/gensio/Makefile
+++ b/net/gensio/Makefile
@@ -33,7 +33,7 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_GENSIO_TCL \
CONFIG_GENSIO_SSHD
-PKG_BUILD_DEPENDS:=PACKAGE_python3-gensio:swig
+PKG_BUILD_DEPENDS:=PACKAGE_python3-gensio:swig/host
include $(INCLUDE_DIR)/package.mk
include ../../lang/python/python3-package.mk
@@ -132,7 +132,7 @@ $(call Package/gensio/Default)
TITLE+= (Python3-bindings)
SECTION:=lang
CATEGORY:=Languages
- DEPENDS:=+PACKAGE_python3-gensio:python3-light +libgensio
+ DEPENDS:=+PACKAGE_python3-gensio:python3-light +libgensiocpp
endef
define Package/python3-gensio/description