aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2023-10-31 10:13:18 +0100
committerGitHub <noreply@github.com>2023-10-31 10:13:18 +0100
commit5ae30e302b18a755af57c99dfee957a85afc1df4 (patch)
tree84bfc0750e7bfe471d0317be65a52e18cce33b57 /net
parent84c431702e97ba70228ec45b60482163fc0d974d (diff)
parentf9ed5a9f3af0c587b29e12f85fd9b82b8394be71 (diff)
Merge pull request #22548 from TDT-AG/pr/20231030-keepalived
keepalived: add script call feature and missing option
Diffstat (limited to 'net')
-rw-r--r--net/keepalived/Makefile2
-rw-r--r--net/keepalived/files/keepalived.init7
2 files changed, 7 insertions, 2 deletions
diff --git a/net/keepalived/Makefile b/net/keepalived/Makefile
index 62f4373f7..da44823c5 100644
--- a/net/keepalived/Makefile
+++ b/net/keepalived/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=keepalived
PKG_VERSION:=2.2.8
-PKG_RELEASE:=3
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.keepalived.org/software
diff --git a/net/keepalived/files/keepalived.init b/net/keepalived/files/keepalived.init
index 63beb2983..cbbff4941 100644
--- a/net/keepalived/files/keepalived.init
+++ b/net/keepalived/files/keepalived.init
@@ -105,6 +105,11 @@ globals() {
printf '%benable_script_security\n' "${INDENT_1}" >> "$KEEPALIVED_CONF"
printf '%bprocess_names\n' "${INDENT_1}" >> "$KEEPALIVED_CONF"
+ printf '%bstartup_script "/bin/busybox env -i ACTION=startup /sbin/hotplug-call keepalived"\n' "${INDENT_1}" >> "$KEEPALIVED_CONF"
+ printf '%bstartup_script_timeout 10\n' "${INDENT_1}" >> "$KEEPALIVED_CONF"
+ printf '%bshutdown_script "/bin/busybox env -i ACTION=shutdown /sbin/hotplug-call keepalived"\n' "${INDENT_1}" >> "$KEEPALIVED_CONF"
+ printf '%bshutdown_script_timeout 10\n' "${INDENT_1}" >> "$KEEPALIVED_CONF"
+
config_get notification_email "$1" notification_email
print_list_indent notification_email
@@ -353,7 +358,7 @@ vrrp_instance() {
garp_master_repeat garp_master_refresh_repeat \
no_val_vmac_xmit_base no_val_native_ipv6 no_val_accept \
no_val_dont_track_primary no_val_smtp_alert no_val_nopreempt \
- no_val_use_vmac
+ no_val_use_vmac no_val_no_accept
print_notify "INSTANCE" "$name" "$INDENT_1" notify_backup notify_master \
notify_fault notify_stop