aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-07-03 20:48:56 -0700
committerRosen Penev <rosenp@gmail.com>2019-07-03 20:58:30 -0700
commit54d7bc119d971d80d700406cab56c58e922a65ab (patch)
tree479ac76cd866fc7cedb02205409fdcbcb30f7f52 /net
parent50abfa2fd75e04fcede2358c812a7c6c08b5ffd7 (diff)
kea: Fix compilation without deprecated OpenSSL APIs
Forgot to add this one to the last pull request. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/kea/Makefile2
-rw-r--r--net/kea/patches/010-openssl-deprecated.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/kea/Makefile b/net/kea/Makefile
index 8ce9823c5..c60ba9d1b 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kea
PKG_VERSION:=1.5.0
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://ftp.isc.org/isc/kea/$(PKG_VERSION)
diff --git a/net/kea/patches/010-openssl-deprecated.patch b/net/kea/patches/010-openssl-deprecated.patch
new file mode 100644
index 000000000..c8b438efc
--- /dev/null
+++ b/net/kea/patches/010-openssl-deprecated.patch
@@ -0,0 +1,11 @@
+--- a/src/lib/cryptolink/openssl_link.cc
++++ b/src/lib/cryptolink/openssl_link.cc
+@@ -79,7 +79,7 @@ CryptoLink::initialize() {
+
+ std::string
+ CryptoLink::getVersion() {
+- return (SSLeay_version(SSLEAY_VERSION));
++ return (OpenSSL_version(OPENSSL_VERSION));
+ }
+
+ } // namespace cryptolink