aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2024-05-03 16:57:38 +0200
committerTianling Shen <cnsztl@gmail.com>2024-05-04 13:14:16 +0800
commit5181ce4a483711791329a13e07d29f9321d85178 (patch)
tree2df6a3b8626e5689576c0ed488d9bf83a5690668 /net
parent69166dbbb709625a848f327c9822c667db39744f (diff)
uspot: update to Git HEAD (2024-05-03)
5e2d15a110bb treewide: remove tip_mode e2dbdef4cf1e treewide: rename spotfilter -> uspotfilter ef0f5291365b uspot/uspotfilter: implement disconnect_delay 92d3356d3fb3 update README Update the package Makefile to reflect the changes from the following above-listed commit: e2dbdef4cf1e treewide: rename spotfilter -> uspotfilter Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
Diffstat (limited to 'net')
-rw-r--r--net/uspot/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/net/uspot/Makefile b/net/uspot/Makefile
index acd584b3a..9477f5cf3 100644
--- a/net/uspot/Makefile
+++ b/net/uspot/Makefile
@@ -8,9 +8,9 @@ PKG_MAINTAINER:=Thibaut VARÈNE <hacks@slashdirt.org>
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/f00b4r0/uspot.git
-PKG_SOURCE_DATE:=2024-03-25
-PKG_SOURCE_VERSION:=094f0df88150ff2c351cfca4fabf76a7edcac79d
-PKG_MIRROR_HASH:=9fb3020bbd6960642bbc59b4448f7922aca3ff50647d1bc6dcf59b8049506587
+PKG_SOURCE_DATE:=2024-05-03
+PKG_SOURCE_VERSION:=92d3356d3fb3ae36199dbd494b5d9a9ae1a9db07
+PKG_MIRROR_HASH:=ae6bb9245945cf207d91b1aa36fb0db2b03333343714c1cacd046dd2c7ee3c79
CMAKE_SOURCE_SUBDIR:=src
@@ -25,7 +25,7 @@ define Package/uspot
EXTRA_DEPENDS:=ucode (>= 2023-11-07)
DEPENDS:=+conntrack \
+libblobmsg-json +liblucihttp-ucode +libradcli +libubox +libubus +libuci \
- +spotfilter \
+ +uspotfilter \
+ucode +ucode-mod-log +ucode-mod-math +ucode-mod-nl80211 +ucode-mod-rtnl +uhttpd-mod-ucode +ucode-mod-uloop
endef
@@ -61,16 +61,14 @@ endef
define Package/uspotfilter
SECTION:=net
CATEGORY:=Network
- TITLE:=uspot implementation of spotfilter
- PROVIDES:=spotfilter
- CONFLICTS:=spotfilter
+ TITLE:=uspot firewall interface
EXTRA_DEPENDS:=ucode (>= 2023-11-07)
DEPENDS:=+conntrack +nftables-json +ucode +ucode-mod-rtnl +ucode-mod-uloop
PKGARCH:=all
endef
define Package/uspotfilter/description
- This package provides the nftables firewall interface to spotfilter.
+ This package provides the nftables firewall interface to uspot.
It is compatible with firewall4.
endef
@@ -91,7 +89,7 @@ endef
define Package/uspotfilter/install
$(INSTALL_DIR) $(1)/usr/share $(1)/etc/init.d
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/files/etc/init.d/spotfilter $(1)/etc/init.d/spotfilter
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/files/etc/init.d/uspotfilter $(1)/etc/init.d/uspotfilter
$(CP) $(PKG_BUILD_DIR)/files/usr/share/uspotfilter $(1)/usr/share/
endef