aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorsbyx <steven@midlink.org>2014-09-18 17:51:57 +0200
committersbyx <steven@midlink.org>2014-09-18 17:51:57 +0200
commit514587f1aed46744fbd76329e44cfe1a012b9505 (patch)
treea4c99b8b7e9d884897fbbc91bd4c097b8f9d78a8 /net
parent906611d5e38ae7894f586f7162d602431c950071 (diff)
parent2e1bfb6f266fc98699fa9ad442d36cf8eb7c762e (diff)
Merge pull request #323 from commodo/master
openvswitch: cleanup and updates
Diffstat (limited to 'net')
-rw-r--r--net/openvswitch/Makefile69
1 files changed, 18 insertions, 51 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index e607d0fe7..710e89845 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -32,8 +32,7 @@ PKG_FIXUP=libtool
define Package/openvswitch/Default
SECTION:=net
CATEGORY:=Network
- URL:=http://www.openvswitchswitch.org/
- DEPENDS:=+libopenssl +librt +libpcap +libatomic
+ URL:=http://openvswitch.org/
MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
endef
@@ -47,48 +46,26 @@ define Package/openvswitch/Default/description
1000V.
endef
-define Package/openvswitch-common
+define Package/openvswitch
$(call Package/openvswitch/Default)
TITLE:=Open vSwitch Userspace Package
- DEPENDS:=+libpcap +libopenssl +librt +kmod-openvswitch
+ DEPENDS:=+libpcap +libopenssl +librt +libatomic +kmod-openvswitch
endef
-define Package/openvswitch-common/description
- openvswitch-common provides components required by openvswitch-switch.
-endef
-
-define Package/openvswitch-ipsec
- $(call Package/openvswitch/Default)
- TITLE:=Open vSwitch Userspace Package
- DEPENDS:=+openvswitch-common
-endef
-
-define Package/openvswitch-ipsec/description
- The ovs-monitor-ipsec script provides support for encrypting GRE tunnels with
- IPsec.
+define Package/openvswitch/description
+ Provides the main userspace components required for Open vSwitch to function.
endef
define Package/openvswitch-benchmark
$(call Package/openvswitch/Default)
TITLE:=Open vSwitch Userspace Package
- DEPENDS:=+openvswitch-common
+ DEPENDS:=@PACKAGE_openvswitch +PACKAGE_openvswitch:openvswitch
endef
define Package/openvswitch-benchmark/description
Utility for running OpenVSwitch benchmarking
endef
-define Package/openvswitch-switch
- $(call Package/openvswitch/Default)
- TITLE:=Open vSwitch Userspace Package
- DEPENDS:=+openvswitch-common
-endef
-
-define Package/openvswitch-switch/description
- openvswitch-switch provides the userspace components and utilities for the
- Open vSwitch kernel-based switch.
-endef
-
define KernelPackage/openvswitch
SECTION:=kernel
CATEGORY:=Kernel modules
@@ -135,17 +112,7 @@ define Build/Compile
KCC="$(KERNEL_CC)"
endef
-define Package/openvswitch-ipsec/install
- $(INSTALL_DIR) $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/debian/ovs-monitor-ipsec $(1)/usr/sbin/
-endef
-
-define Package/openvswitch-benchmark/install
- $(INSTALL_DIR) $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-benchmark $(1)/usr/bin/
-endef
-
-define Package/openvswitch-common/install
+define Package/openvswitch/install
$(INSTALL_DIR) $(1)/etc/openvswitch
$(INSTALL_DIR) $(1)/etc/init.d
@@ -161,15 +128,7 @@ define Package/openvswitch-common/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-appctl $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-ofctl $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ovsdb/.libs/ovsdb-client $(1)/usr/bin/
-endef
-define Package/openvswitch-common/postinst
-#!/bin/sh
-[ -n "$${IPKG_INSTROOT}" ] || /etc/init.d/openvswitch enable || true
-endef
-
-define Package/openvswitch-switch/install
- $(INSTALL_DIR) $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-dpctl $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-vsctl $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ovsdb/.libs/ovsdb-tool $(1)/usr/bin/
@@ -182,9 +141,17 @@ define Package/openvswitch-switch/install
$(INSTALL_CONF) $(PKG_BUILD_DIR)/vswitchd/vswitch.ovsschema $(1)/usr/share/openvswitch/
endef
-$(eval $(call BuildPackage,openvswitch-ipsec))
-$(eval $(call BuildPackage,openvswitch-common))
-$(eval $(call BuildPackage,openvswitch-switch))
+define Package/openvswitch-benchmark/install
+ $(INSTALL_DIR) $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-benchmark $(1)/usr/bin/
+endef
+
+define Package/openvswitch/postinst
+#!/bin/sh
+[ -n "$${IPKG_INSTROOT}" ] || /etc/init.d/openvswitch enable || true
+endef
+
+$(eval $(call BuildPackage,openvswitch))
$(eval $(call BuildPackage,openvswitch-benchmark))
$(eval $(call KernelPackage,openvswitch))