aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-05-17 11:36:50 -0700
committerGitHub <noreply@github.com>2019-05-17 11:36:50 -0700
commit50fc3e27b30c213b50d4d6a654f430d9752d1ae4 (patch)
treee60bd07c6a3c260ef1c33a648903d4310cb7c684 /net
parent675fab7c432897764817f5422816e633db8ba489 (diff)
parent4108353ec15ee197cc42d29859ddc09e147b72bb (diff)
Merge pull request #8900 from neheb/por
port-mirroring: Update to 1.4.4
Diffstat (limited to 'net')
-rw-r--r--net/port-mirroring/Makefile2
-rw-r--r--net/port-mirroring/patches/010-snprintf-to-strncpy.patch20
2 files changed, 21 insertions, 1 deletions
diff --git a/net/port-mirroring/Makefile b/net/port-mirroring/Makefile
index 6c32174ee..a001e47ed 100644
--- a/net/port-mirroring/Makefile
+++ b/net/port-mirroring/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=port-mirroring
PKG_VERSION:=1.4.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/mmaraya/port-mirroring/tar.gz/v$(PKG_VERSION)?
diff --git a/net/port-mirroring/patches/010-snprintf-to-strncpy.patch b/net/port-mirroring/patches/010-snprintf-to-strncpy.patch
new file mode 100644
index 000000000..d28c2e23a
--- /dev/null
+++ b/net/port-mirroring/patches/010-snprintf-to-strncpy.patch
@@ -0,0 +1,20 @@
+--- a/src/main.c
++++ b/src/main.c
+@@ -90,7 +90,7 @@ int loadCfg(const char *fpath)
+ }
+ else
+ {
+- snprintf(cfg.dst_if, IFNAMSIZ, "%s", value);
++ strncpy(cfg.dst_if, value, IFNAMSIZ);
+ cfg.flags |= PM_DST_IF;
+ }
+ }
+@@ -104,7 +104,7 @@ int loadCfg(const char *fpath)
+ }
+ else if (strcmp(option, "filter") == 0)
+ {
+- snprintf(cfg.pfe, PFE_MAX, "%s", value);
++ strncpy(cfg.pfe, value, PFE_MAX);
+ }
+ else if (strcmp(option, "promiscuous") == 0)
+ {