aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2024-02-21 08:41:19 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2024-02-22 09:31:44 +0800
commit4d1c7a144ab06dfdad6b11a90a364e7f88a976c3 (patch)
treef2297dad1e4baf53db16544cf5a6950e909d811e /net
parent7ccbb9a66cfadba035e2ad95a7931877e5faf504 (diff)
ovn: bump to 22.03.5
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/ovn/Makefile4
-rw-r--r--net/ovn/patches/0002-build-skip-tests-and-docs.patch2
-rw-r--r--net/ovn/patches/0004-fix-use-of-possible-uninitialized-var.patch2
3 files changed, 4 insertions, 4 deletions
diff --git a/net/ovn/Makefile b/net/ovn/Makefile
index 999986f93..186fb9596 100644
--- a/net/ovn/Makefile
+++ b/net/ovn/Makefile
@@ -9,13 +9,13 @@ include $(INCLUDE_DIR)/kernel.mk
include ../openvswitch/openvswitch.mk
PKG_NAME:=ovn
-PKG_VERSION:=22.03.0
+PKG_VERSION:=22.03.5
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/ovn-org/ovn.git
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
-PKG_MIRROR_HASH:=eb494796a7a21e7c1ba5b3f60c037385eb5f0c33007ebc627437f36187f860fe
+PKG_MIRROR_HASH:=2fce32762c4f8f21ba10f2d41924188cd995bea56eb9a09a7a119b15b9c60224
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
diff --git a/net/ovn/patches/0002-build-skip-tests-and-docs.patch b/net/ovn/patches/0002-build-skip-tests-and-docs.patch
index 12ef25de0..4d651d17a 100644
--- a/net/ovn/patches/0002-build-skip-tests-and-docs.patch
+++ b/net/ovn/patches/0002-build-skip-tests-and-docs.patch
@@ -10,7 +10,7 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
--- a/Makefile.am
+++ b/Makefile.am
-@@ -483,11 +483,9 @@ dist-docs:
+@@ -478,11 +478,9 @@ dist-docs:
include automake.mk
diff --git a/net/ovn/patches/0004-fix-use-of-possible-uninitialized-var.patch b/net/ovn/patches/0004-fix-use-of-possible-uninitialized-var.patch
index 21b90ec10..258f8e607 100644
--- a/net/ovn/patches/0004-fix-use-of-possible-uninitialized-var.patch
+++ b/net/ovn/patches/0004-fix-use-of-possible-uninitialized-var.patch
@@ -10,7 +10,7 @@ ic/ovn-ic.c:430:40: note: 'ls' was declared here
--- a/ic/ovn-ic.c
+++ b/ic/ovn-ic.c
-@@ -427,7 +427,7 @@ find_ts_in_nb(struct ic_context *ctx, ch
+@@ -433,7 +433,7 @@ find_ts_in_nb(struct ic_context *ctx, ch
nbrec_logical_switch_index_init_row(ctx->nbrec_ls_by_name);
nbrec_logical_switch_index_set_name(key, ts_name);