aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2019-04-05 17:36:16 +0200
committerAnsuel Smith <ansuelsmth@gmail.com>2019-04-05 21:54:53 +0200
commit4b541141ca44eff99c9f8be0cc3b24773277308c (patch)
treefb11d161e7beb68b9239b0bd4f67132d6a3e2144 /net
parentd92d34db5a382997e3d9230247644e55a1d84602 (diff)
nginx: update to version 1.15.10 and rework
Remove libopenssl dep from NGINX_HTTP_CACHE and NGINX_HTTP_AUTH_BASIC config flag The documentation doesn't mention that openssl is required for this 2 modules. This also permit to use nginx no-ssl variant without libopenssl as this 2 module are selected by default. Also make OPENSSL_ENGINE flag a dep to recompile nginx on change of openssl compilation flag. Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/nginx/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index 4a5272059..17794f87f 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nginx
-PKG_VERSION:=1.15.8
+PKG_VERSION:=1.15.10
PKG_RELEASE:=1
PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://nginx.org/download/
-PKG_HASH:=a8bdafbca87eb99813ae4fcac1ad0875bf725ce19eb265d28268c309b2b40787
+PKG_HASH:=b865743abd52bce4745d0f7e7fedde3cafbaaab617b022c105e3e4e456537c3c
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de> \
Ansuel Smith <ansuelsmth@gmail.com>
@@ -71,6 +71,7 @@ PKG_CONFIG_DEPENDS := \
CONFIG_NGINX_STREAM_SSL_PREREAD_MODULE \
CONFIG_NGINX_RTMP_MODULE \
CONFIG_NGINX_TS_MODULE \
+ CONFIG_OPENSSL_ENGINE \
include $(INCLUDE_DIR)/package.mk
@@ -80,7 +81,7 @@ define Package/nginx/default
SUBMENU:=Web Servers/Proxies
TITLE:=Nginx web server
URL:=http://nginx.org/
- DEPENDS:=+NGINX_PCRE:libpcre +(NGINX_SSL||NGINX_HTTP_CACHE||NGINX_HTTP_AUTH_BASIC):libopenssl \
+ DEPENDS:=+NGINX_PCRE:libpcre +NGINX_SSL:libopenssl \
+NGINX_HTTP_GZIP:zlib +NGINX_LUA:liblua +libpthread +NGINX_DAV:libexpat
endef
@@ -104,7 +105,7 @@ define Package/nginx-ssl
endef
Package/nginx-ssl/description = $(Package/nginx/description) \
- This varian is compiled with SSL support enabled. To enable additional module \
+ This variant is compiled with SSL support enabled. To enable additional module \
select them in the nginx default configuration menu.
define Package/nginx-all-module
@@ -116,7 +117,7 @@ define Package/nginx-all-module
endef
Package/nginx-all-module/description = $(Package/nginx/description) \
- This varian is compiled with ALL module selected.
+ This variant is compiled with ALL module selected.
define Package/nginx/config
source "$(SOURCE)/Config.in"