aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-07-27 08:11:12 +0300
committerGitHub <noreply@github.com>2021-07-27 08:11:12 +0300
commit4b4a3b7b87dfa95d15fc373dd7d06317d3fcc939 (patch)
treef8fb5afa4259e73d3c3fb5a278b8e097081a56b0 /net
parent2e0b72910ad433674eac9f829d213481001619d8 (diff)
parent45c8cc9d8a7b80e9405009765b28a519a5c04e51 (diff)
Merge pull request #16211 from stintel/ovs-libunbound-optional
openvswitch: make libunbound optional
Diffstat (limited to 'net')
-rw-r--r--net/openvswitch/Config.in8
-rw-r--r--net/openvswitch/Makefile11
2 files changed, 17 insertions, 2 deletions
diff --git a/net/openvswitch/Config.in b/net/openvswitch/Config.in
new file mode 100644
index 000000000..ba17072f8
--- /dev/null
+++ b/net/openvswitch/Config.in
@@ -0,0 +1,8 @@
+menu "Configuration"
+ depends on PACKAGE_openvswitch
+
+ config OPENVSWITCH_WITH_LIBUNBOUND
+ bool
+ default y
+ prompt "Build with libunbound library."
+endmenu
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index c2c1f8fac..5ee65326d 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -17,7 +17,7 @@ include ./openvswitch.mk
#
PKG_NAME:=openvswitch
PKG_VERSION:=$(ovs_version)
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.openvswitch.org/releases/
PKG_HASH:=7d5797f2bf2449c6a266149e88f72123540f7fe7f31ad52902057ae8d8f88c38
@@ -40,6 +40,9 @@ include $(INCLUDE_DIR)/package.mk
include ../../lang/python/python3-host.mk
include ../../lang/python/python3-package.mk
+define Package/openvswitch/config
+source "$(SOURCE)/Config.in"
+endef
ovs_kmod_packages:=
ovs_kmod_intree_kernel_patchver_min:=3.10
@@ -150,8 +153,11 @@ $(eval $(call OvsKmodPackageTemplate,openvswitch-lisp-intree))
#
ovs_libopenvswitch_title:=Open vSwitch (libopenvswitch.so)
ovs_libopenvswitch_hidden:=1
-ovs_libopenvswitch_depends:=+libopenssl +libunbound +!(arc||arceb):libunwind
+ovs_libopenvswitch_depends:=+libopenssl +!(arc||arceb):libunwind
ovs_libopenvswitch_depends+=+libatomic
+ifeq ($(CONFIG_KEEPALIVED_ROUTES),y)
+ovs_libopenvswitch_depends+=+libunbound
+endif
ovs_libopenvswitch_files:=usr/lib/libopenvswitch*.so*
$(eval $(call OvsPackageTemplate,libopenvswitch))
@@ -243,6 +249,7 @@ CONFIGURE_ARGS+= \
--disable-silent-rules \
CONFIGURE_VARS += \
+ $(if $(CONFIG_OPENVSWITCH_WITH_UNBOUND),,ac_cv_lib_unbound_ub_ctx_create=no) \
ovs_cv_flake8=no \
ovs_cv_python3=$(PYTHON3) \
ovs_cv_python3_host=$(HOST_PYTHON3_BIN) \