aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2022-08-16 21:29:57 +0200
committerRosen Penev <rosenp@gmail.com>2022-08-16 13:11:43 -0700
commit49b85f9b5049e11d8bf1141de101212b530124d0 (patch)
tree3e2323ff651233abc4e66e9e1217aba11ad92c94 /net
parentc1a96acc359ea0a9c4a562f9eaa70a82aec4efb5 (diff)
sslh: install sslh-select
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'net')
-rw-r--r--net/sslh/Makefile13
-rw-r--r--net/sslh/patches/001-configfile-fix.patch (renamed from net/sslh/patches/002-configfile-fix.patch)0
-rw-r--r--net/sslh/patches/001-no_sslh_select.patch31
3 files changed, 13 insertions, 31 deletions
diff --git a/net/sslh/Makefile b/net/sslh/Makefile
index c8527d157..cc2b7211a 100644
--- a/net/sslh/Makefile
+++ b/net/sslh/Makefile
@@ -30,6 +30,15 @@ define Package/sslh
URL:=https://rutschle.net/tech/sslh/README.html
endef
+define Package/sslh/config
+ config SSLH_SELECT
+ bool "Use sslh-select"
+ depends on PACKAGE_sslh
+ help
+ Use sslh-select instead of sslh-fork.
+ default n
+endef
+
define Package/sslh/conffiles
/etc/config/sslh
/etc/sslh.conf
@@ -40,7 +49,11 @@ MAKE_FLAGS += \
define Package/sslh/install
$(INSTALL_DIR) $(1)/usr/sbin
+ifeq ($(CONFIG_SSLH_SELECT),y)
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/sslh-select $(1)/usr/sbin/sslh
+else
$(INSTALL_BIN) $(PKG_BUILD_DIR)/sslh-fork $(1)/usr/sbin/sslh
+endif
$(INSTALL_DIR) $(1)/etc/init.d/
$(INSTALL_BIN) files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
$(INSTALL_DIR) $(1)/etc/config
diff --git a/net/sslh/patches/002-configfile-fix.patch b/net/sslh/patches/001-configfile-fix.patch
index d9344cdaa..d9344cdaa 100644
--- a/net/sslh/patches/002-configfile-fix.patch
+++ b/net/sslh/patches/001-configfile-fix.patch
diff --git a/net/sslh/patches/001-no_sslh_select.patch b/net/sslh/patches/001-no_sslh_select.patch
deleted file mode 100644
index 0b57757dc..000000000
--- a/net/sslh/patches/001-no_sslh_select.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -70,7 +70,7 @@ all: sslh $(MAN) echosrv $(CONDITIONAL_T
- version.h:
- ./genver.sh >version.h
-
--sslh: sslh-fork sslh-select
-+sslh: sslh-fork
-
- $(OBJS): version.h common.h collection.h sslh-conf.h gap.h
-
-@@ -81,10 +81,6 @@ sslh-fork: version.h $(OBJS) sslh-fork.o
- $(CC) $(CFLAGS) $(LDFLAGS) -o sslh-fork sslh-fork.o $(OBJS) $(LIBS)
- #strip sslh-fork
-
--sslh-select: version.h $(OBJS) sslh-select.o Makefile
-- $(CC) $(CFLAGS) $(LDFLAGS) -o sslh-select sslh-select.o $(OBJS) $(LIBS)
-- #strip sslh-select
--
- systemd-sslh-generator: systemd-sslh-generator.o
- $(CC) $(CFLAGS) $(LDFLAGS) -o systemd-sslh-generator systemd-sslh-generator.o -lconfig
-
-@@ -133,7 +129,7 @@ distclean: clean
- rm -f tags sslh-conf.[ch] echosrv-conf.[ch] cscope.*
-
- clean:
-- rm -f sslh-fork sslh-select echosrv version.h $(MAN) systemd-sslh-generator *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info
-+ rm -f sslh-fork echosrv version.h $(MAN) systemd-sslh-generator *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info
-
- tags:
- ctags --globals -T *.[ch]