aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorsbyx <steven@midlink.org>2014-07-16 11:19:56 +0200
committersbyx <steven@midlink.org>2014-07-16 11:19:56 +0200
commit483e09bdb20ec905e9ee182aa8e0eb285f2de920 (patch)
tree55841c7844e6abcb21ffb8e6660a3e81d3a17017 /net
parent94c1946aba215730c39d9fb65a89c224d0a7f83a (diff)
parentcebfdc69929dc4e6b948177ea1dc296250309ee8 (diff)
Merge pull request #98 from salzmdan/master
knot: update to 1.5.0.
Diffstat (limited to 'net')
-rw-r--r--net/knot/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/net/knot/Makefile b/net/knot/Makefile
index 91b1ed4e7..fbb353367 100644
--- a/net/knot/Makefile
+++ b/net/knot/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=knot
-PKG_VERSION:=1.5.0-rc2
+PKG_VERSION:=1.5.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-dns/
-PKG_MD5SUM:=9a93226c200813ee7bfe27dcf7b6cbc9
+PKG_MD5SUM:=d677de99c19afea3b1e8ef075a9d5a8b
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_BUILD_PARALLEL:=1
@@ -73,9 +73,14 @@ define Package/knot-tests/description
Usage: /usr/share/knot/runtests.sh
endef
+define Package/knot/conffiles
+/etc/knot/knot.conf
+endef
+
CONFIGURE_ARGS += \
--enable-recvmmsg=no \
--disable-fastparser \
+ --without-libidn \
--with-rundir=/var/run \
--with-storage=/etc/knot
@@ -101,7 +106,7 @@ define Package/knot/install
$(INSTALL_DIR) $(1)/etc/knot
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/knot/knot.sample.conf $(1)/etc/knot/knot.conf
- $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/knot/example.com.zone $(1)/etc/knot/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/knot/example.com.zone $(1)/etc/knot/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/knotd.init $(1)/etc/init.d/knotd
@@ -117,7 +122,7 @@ endef
define Package/knot-tests/install
$(INSTALL_DIR) $(1)/usr/share/knot
- $(INSTALL_BIN) ./files/runtests.sh $(1)/usr/share/knot
+ $(INSTALL_BIN) ./files/runtests.sh $(1)/usr/share/knot/
$(INSTALL_DIR) $(1)/usr/share/knot/tap
$(INSTALL_BIN) $(PKG_BUILD_DIR)/libtap/runtests $(1)/usr/share/knot/tap/
@@ -129,11 +134,11 @@ define Package/knot-tests/install
xargs -I{} $(INSTALL_BIN) -T $(PKG_BUILD_DIR)/tests/.libs/{} $(1)/usr/share/knot/tests/test_{}
$(INSTALL_DIR) $(1)/usr/share/knot/tests/data
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/tests/data/sample_conf $(1)/usr/share/knot/tests/data/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/tests/data/sample_conf $(1)/usr/share/knot/tests/data/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/zscanner/tests/.libs/zscanner-tool $(1)/usr/share/knot/tests/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/zscanner/tests/unittests $(1)/usr/share/knot/tests/test_zscanner
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/zscanner/tests/TESTS $(1)/usr/share/knot/tests/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/src/zscanner/tests/TESTS $(1)/usr/share/knot/tests/
cp -a $(PKG_BUILD_DIR)/src/zscanner/tests/data $(1)/usr/share/knot/tests/
endef