aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPaul Donald <newtwen+github@gmail.com>2024-03-31 20:25:17 +0200
committerRosen Penev <rosenp@gmail.com>2024-04-26 14:53:06 -0700
commit4628b6bd43ac1c212363535fe4d32739c5f7e622 (patch)
treed24bc417c0cf389ffe91031812f510df160dca7a /net
parent2c6d5adac049a55ca067255da90dc938b5604249 (diff)
p910nd: set bidi only if not already set
Closes #23774 Signed-off-by: Paul Donald <newtwen+github@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/p910nd/Makefile2
-rw-r--r--net/p910nd/files/p910nd.hotplug3
2 files changed, 2 insertions, 3 deletions
diff --git a/net/p910nd/Makefile b/net/p910nd/Makefile
index c8934779a..3e866590c 100644
--- a/net/p910nd/Makefile
+++ b/net/p910nd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=p910nd
PKG_VERSION:=0.97
-PKG_RELEASE:=13
+PKG_RELEASE:=14
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/p910nd
diff --git a/net/p910nd/files/p910nd.hotplug b/net/p910nd/files/p910nd.hotplug
index 3440a86ed..2bebaee84 100644
--- a/net/p910nd/files/p910nd.hotplug
+++ b/net/p910nd/files/p910nd.hotplug
@@ -281,8 +281,7 @@ get_and_store_printer_info() {
[ "$DEBUG" ] && echo ${MFG:+MFG=$MFG} ${MDL:+MDL=$MDL} ${CMD:+CMD=$CMD} ${CLS:+CLS=$CLS} ${DES:+DES=$DES} ${SN:+SN=$SN}
[ "$DEBUG" ] && echo 'uci set' for UCI_DEV_CFG_NUMBER: $UCI_DEV_CFG_NUMBER
- # Take the USB info as fact: set bidir regardless. It seems to be a source of confusion.
- eval "$uqsddu_cmd.bidirectional='$BIDIR'"
+ [ -z "$(eval "$uqgddu_cmd".bidirectional)" ] && eval "$uqsddu_cmd.bidirectional='$BIDIR'"
[ -z "$(eval "$uqgddu_cmd".port)" ] && eval "$uqsddu_cmd.port='0'"
[ -z "$(eval "$uqgddu_cmd".enabled)" ] && eval "$uqsddu_cmd.enabled='1'"
[ -z "$(eval "$uqgddu_cmd".usbvidpid)" ] && [ -n "$THIS_USB_VIDPID" ] && eval "$uqsddu_cmd.usbvidpid='$THIS_USB_VIDPID'"