aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorDirk Brenken <dev@brenken.org>2017-06-10 07:56:32 +0200
committerDirk Brenken <dev@brenken.org>2017-06-10 07:56:32 +0200
commit457b517b8ab6a4cfa4805ed66574e20944e90f89 (patch)
tree02e3db5cb1a306d27aa4e79b205a9bcc3397845e /net
parentbf6636517a917f3386a429b9dd5cf1590165926c (diff)
travelmate: maintenance update 0.7.5
* fix wrong connection status in case of an error * documentation update Signed-off-by: Dirk Brenken <dev@brenken.org>
Diffstat (limited to 'net')
-rw-r--r--net/travelmate/Makefile2
-rw-r--r--net/travelmate/files/README.md7
-rwxr-xr-xnet/travelmate/files/travelmate.sh3
3 files changed, 7 insertions, 5 deletions
diff --git a/net/travelmate/Makefile b/net/travelmate/Makefile
index fd7d2b85c..0fb886564 100644
--- a/net/travelmate/Makefile
+++ b/net/travelmate/Makefile
@@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=travelmate
-PKG_VERSION:=0.7.4
+PKG_VERSION:=0.7.5
PKG_RELEASE:=1
PKG_LICENSE:=GPL-3.0+
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/travelmate/files/README.md b/net/travelmate/files/README.md
index 3d3f82101..0e30dd3d9 100644
--- a/net/travelmate/files/README.md
+++ b/net/travelmate/files/README.md
@@ -24,8 +24,9 @@ To avoid these kind of deadlocks, travelmate set all station interfaces in an "a
* download the package [here](https://downloads.lede-project.org/snapshots/packages/x86_64/packages)
* install 'travelmate' (_opkg install travelmate_)
* configure your network:
- * automatic: use the LuCI frontend with automatic interface setup, that's the recommended way
+ * automatic: use the LuCI frontend with automatic STA interface setup, that's the recommended way
* manual: see detailed configure steps below
+ * at least you need one AP and one STA interface configured
## LuCI travelmate companion package
* download the package [here](https://downloads.lede-project.org/snapshots/packages/x86_64/luci)
@@ -59,7 +60,7 @@ root@adb2go:~# /etc/init.d/travelmate status
system : LEDE Reboot SNAPSHOT r4051-3ddc1914ba
</code></pre>
-## Setup
+## Manual Setup
**1. configure the travelmate wwan interface in /etc/config/network:**
<pre><code>
[...]
@@ -77,7 +78,7 @@ config zone
[...]
</code></pre>
-**3. add required ap and wwan stations to your wireless configuration in etc/config/wireless:**
+**3. at least add one ap and (multiple) wwan stations to your wireless configuration in etc/config/wireless:**
<pre><code>
[...]
config wifi-iface
diff --git a/net/travelmate/files/travelmate.sh b/net/travelmate/files/travelmate.sh
index 01da61703..5ae1a93ab 100755
--- a/net/travelmate/files/travelmate.sh
+++ b/net/travelmate/files/travelmate.sh
@@ -10,7 +10,7 @@
#
LC_ALL=C
PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-trm_ver="0.7.4"
+trm_ver="0.7.5"
trm_sysver="$(ubus -S call system board | jsonfilter -e '@.release.description')"
trm_enabled=0
trm_debug=0
@@ -257,6 +257,7 @@ f_main()
done
if [ ! -s "${trm_rtfile}" ]
then
+ trm_ifstatus="false"
f_jsnupdate "n/a" "n/a" "n/a"
fi
else