aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorToke Høiland-Jørgensen <toke@toke.dk>2020-08-09 10:14:25 +0200
committerGitHub <noreply@github.com>2020-08-09 10:14:25 +0200
commit416dccf72a82b624c9f42f2f4a6553439721a49f (patch)
treeec089accb68189ccde88b6954f1931df935e7fc5 /net
parent5be1783bfefbbc686ca44648ef7d8271e4468caf (diff)
parentc332d5fdf70e32a109621bed7f6b0198ca858172 (diff)
Merge pull request #13058 from guidosarducci/master-fix-gcc10-netperf
netperf: fix compilation with GCC10
Diffstat (limited to 'net')
-rw-r--r--net/netperf/Makefile2
-rw-r--r--net/netperf/patches/010-gcc10_multiple_definition_fix.patch19
2 files changed, 20 insertions, 1 deletions
diff --git a/net/netperf/Makefile b/net/netperf/Makefile
index 032ded586..9564a4c60 100644
--- a/net/netperf/Makefile
+++ b/net/netperf/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=netperf
PKG_VERSION:=2.7.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=Custom
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/net/netperf/patches/010-gcc10_multiple_definition_fix.patch b/net/netperf/patches/010-gcc10_multiple_definition_fix.patch
new file mode 100644
index 000000000..3a1e0101e
--- /dev/null
+++ b/net/netperf/patches/010-gcc10_multiple_definition_fix.patch
@@ -0,0 +1,19 @@
+--- a/src/nettest_omni.c
++++ b/src/nettest_omni.c
+@@ -454,16 +454,6 @@ static int remote_cpu_method;
+ static int client_port_min = 5000;
+ static int client_port_max = 65535;
+
+- /* different options for the sockets */
+-
+-int
+- loc_nodelay, /* don't/do use NODELAY locally */
+- rem_nodelay, /* don't/do use NODELAY remotely */
+- loc_sndavoid, /* avoid send copies locally */
+- loc_rcvavoid, /* avoid recv copies locally */
+- rem_sndavoid, /* avoid send copies remotely */
+- rem_rcvavoid; /* avoid recv_copies remotely */
+-
+ extern int
+ loc_tcpcork,
+ rem_tcpcork,