aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-25 16:01:34 -0700
committerRosen Penev <rosenp@gmail.com>2020-06-27 14:14:46 -0700
commit3f00aed153934ee0ee27e0605d6f9f2bbacd9695 (patch)
tree424fe48f4b118b728d44be4214d656a5445e57e7 /net
parentf10023094ee336eaf070e4cbb893bccfeb7f43b7 (diff)
rsync: update to 3.2.1
Disable several options to enable compilation. Simplified several configure options. Remove pointless configure var. Added ssh hinting patch. Some SSH incompatibility. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/rsync/Makefile47
-rw-r--r--net/rsync/patches/010-disable-ssh-46-hint.patch19
2 files changed, 36 insertions, 30 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index a0c6b4569..ff4231a1a 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rsync
-PKG_VERSION:=3.1.3
-PKG_RELEASE:=3
+PKG_VERSION:=3.2.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.samba.org/pub/rsync/src
-PKG_HASH:=55cc554efec5fdaad70de921cd5a5eeb6c29a95524c715f3bbf849235b0800c0
+PKG_HASH:=95f2dd62979b500a99b34c1a6453a0787ada0330e4bec7fcffad37b9062d58d3
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
PKG_LICENSE:=GPL-3.0-or-later
@@ -40,35 +40,22 @@ define Package/rsync/config
endef
CONFIGURE_ARGS += \
- --with-included-popt=no \
+ --without-included-popt \
--disable-debug \
+ --disable-asm \
+ --disable-iconv \
+ --disable-iconv-open \
+ --disable-lz4 \
--disable-locale \
-
-ifeq ($(CONFIG_RSYNC_xattr),y)
- CONFIGURE_ARGS+= --enable-xattr-support
-else
- CONFIGURE_ARGS+= --disable-xattr-support
-endif
-
-ifeq ($(CONFIG_RSYNC_acl),y)
- CONFIGURE_ARGS+= --enable-acl-support
-else
- CONFIGURE_ARGS+= --disable-acl-support
-endif
-
-ifeq ($(CONFIG_RSYNC_zlib),y)
- CONFIGURE_ARGS+= --with-included-zlib=no
-else
- CONFIGURE_ARGS+= --with-included-zlib=yes
-endif
-
-ifeq ($(CONFIG_IPV6),y)
- TARGET_CFLAGS+= -DINET6
-else
- CONFIGURE_ARGS+= --disable-ipv6
-endif
-
-CONFIGURE_VARS += rsync_cv_HAVE_GETTIMEOFDAY_TZ=yes
+ --disable-md2man \
+ --disable-openssl \
+ --disable-simd \
+ --disable-xxhash \
+ --disable-zstd \
+ --$(if $(CONFIG_RSYNC_xattr),en,dis)able-xattr-support \
+ --$(if $(CONFIG_RSYNC_acl),en,dis)able-acl-support \
+ --with$(if $(CONFIG_RSYNC_zlib),,out)-included-zlib \
+ --$(if $(CONFIG_IPV6),en,dis)able-ipv6
define Package/rsyncd
SECTION:=net
diff --git a/net/rsync/patches/010-disable-ssh-46-hint.patch b/net/rsync/patches/010-disable-ssh-46-hint.patch
new file mode 100644
index 000000000..cecee5403
--- /dev/null
+++ b/net/rsync/patches/010-disable-ssh-46-hint.patch
@@ -0,0 +1,19 @@
+diff --git a/main.c b/main.c
+index b41a394..dd49f87 100644
+--- a/main.c
++++ b/main.c
+@@ -572,14 +572,6 @@ static pid_t do_cmd(char *cmd, char *machine, char *user, char **remote_argv, in
+ args[argc++] = "-l";
+ args[argc++] = user;
+ }
+-#ifdef AF_INET
+- if (default_af_hint == AF_INET && strcmp(t, "ssh") == 0)
+- args[argc++] = "-4"; /* we're using ssh so we can add a -4 option */
+-#endif
+-#ifdef AF_INET6
+- if (default_af_hint == AF_INET6 && strcmp(t, "ssh") == 0)
+- args[argc++] = "-6"; /* we're using ssh so we can add a -6 option */
+-#endif
+ args[argc++] = machine;
+ #endif
+