aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorChristian Schoenebeck <christian.schoenebeck@gmail.com>2016-03-05 21:44:19 +0100
committerChristian Schoenebeck <christian.schoenebeck@gmail.com>2016-03-05 21:44:19 +0100
commit38866917d85e513436b61be464c07f8454f3edac (patch)
treee611b699f76920b6a8951f75be24911602b08c51 /net
parentdb993dc673835feffb23656cce29be2080617e92 (diff)
ddns-scripts: correct freedns.afraid.org update url and new provider
- roll back to "old" update_url of freedns.afraid.org fix for #2445 and openwrt/luci#661 - add provider nubem.com (IPv4 only) - add provider nettica.com (IPv4 only) - add provider zerigo.com (IPv4 and IPv6) - add provider regfish.de (IPv4 and IPv6) Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
Diffstat (limited to 'net')
-rwxr-xr-xnet/ddns-scripts/Makefile4
-rwxr-xr-xnet/ddns-scripts/files/dynamic_dns_functions.sh2
-rw-r--r--net/ddns-scripts/files/services16
-rw-r--r--net/ddns-scripts/files/services_ipv69
4 files changed, 26 insertions, 5 deletions
diff --git a/net/ddns-scripts/Makefile b/net/ddns-scripts/Makefile
index 33544bdfc..7671ffcd5 100755
--- a/net/ddns-scripts/Makefile
+++ b/net/ddns-scripts/Makefile
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ddns-scripts
# Version == major.minor.patch
# increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.6.2
+PKG_VERSION:=2.6.3
# Release == build
# increase on changes of services files or tld_names.dat
-PKG_RELEASE:=3
+PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
diff --git a/net/ddns-scripts/files/dynamic_dns_functions.sh b/net/ddns-scripts/files/dynamic_dns_functions.sh
index 438ba21d3..1f98f7520 100755
--- a/net/ddns-scripts/files/dynamic_dns_functions.sh
+++ b/net/ddns-scripts/files/dynamic_dns_functions.sh
@@ -21,7 +21,7 @@
. /lib/functions/network.sh
# GLOBAL VARIABLES #
-VERSION="2.6.1-1"
+VERSION="2.6.3-1"
SECTION_ID="" # hold config's section name
VERBOSE_MODE=1 # default mode is log to console, but easily changed with parameter
diff --git a/net/ddns-scripts/files/services b/net/ddns-scripts/files/services
index e961efd96..d62032d6c 100644
--- a/net/ddns-scripts/files/services
+++ b/net/ddns-scripts/files/services
@@ -37,7 +37,9 @@
"changeip.com" "http://[USERNAME]:[PASSWORD]@nic.changeip.com/nic/update?u=[USERNAME]&p=[PASSWORD]&cmd=update&hostname=[DOMAIN]&ip=[IP]"
"zoneedit.com" "http://[USERNAME]:[PASSWORD]@dynamic.zoneedit.com/auth/dynamic.html?host=[DOMAIN]&dnsto=[IP]"
"free.editdns.net" "http://dyndns-free.editdns.net/api/dynLinux.php?p=[PASSWORD]&r=[DOMAIN]"
-"freedns.afraid.org" "http://[USERNAME]:[PASSWORD]@freedns.afraid.org/nic/update?hostname=[DOMAIN]&myip=[IP]"
+
+# freedns.afraid.org is weird, you just need an update code, for which we use the password variable
+"freedns.afraid.org" "http://freedns.afraid.org/dynamic/update.php?[PASSWORD]&address=[IP]"
# DNS Max and resellers' update urls
"dnsmax.com" "http://update.dnsmax.com/update/?username=[USERNAME]&password=[PASSWORD]&resellerid=1&clientname=openwrt&clientversion=8.09&protocolversion=2.0&updatehostname=[DOMAIN]&ip=[IP]"
@@ -120,3 +122,15 @@
# dynu.com
"dynu.com" "http://api.dynu.com/nic/update?hostname=[DOMAIN]&myip=[IP]&username=[USERNAME]&password=[PASSWORD]"
+
+# nubem.com
+"nubem.com" "http://[USERNAME]:[PASSWORD]@nubem.com/nic/update?hostname=[DOMAIN]&myip=[IP]"
+
+# nettica.com
+"nettica.com" "http://www.nettica.com/Domain/Update.aspx?U=[USERNAME]&PC=[PASSWORD]&FQDN=[DOMAIN]&N=[IP]"
+
+# zerigo.com
+"zerigo.com" "http://update.zerigo.com/dynamic?host=[DOMAIN]&ip=[IP]&user=[USERNAME]&password=[PASSWORD]"
+
+# regfish.de
+"regfish.de" "http://dyndns.regfish.de/?fqdn=[DOMAIN]&forcehost=1&authtype=secure&token=[PASSWORD]&ipv4=[IP]" "success|100|101"
diff --git a/net/ddns-scripts/files/services_ipv6 b/net/ddns-scripts/files/services_ipv6
index 941f0c08c..b6e5997f9 100644
--- a/net/ddns-scripts/files/services_ipv6
+++ b/net/ddns-scripts/files/services_ipv6
@@ -57,5 +57,12 @@
# IPv6 @ Dyn.com
"dyndns.org" "http://[USERNAME]:[PASSWORD]@members.dyndns.org/nic/update?hostname=[DOMAIN]&myip=[IP]"
-# zzzz.io Free Dynamic DNS
+# IPv6 @ zzzz.io Free Dynamic DNS
"zzzz.io" "https://zzzz.io/api/v1/update/[DOMAIN]/?token=[PASSWORD]&type=aaaa&ip=[IP]" "Updated|No change"
+
+# IPv6 @ zerigo.com
+"zerigo.com" "http://update.zerigo.com/dynamic?host=[DOMAIN]&ip=[IP]&user=[USERNAME]&password=[PASSWORD]"
+
+# IPv6 @ regfish.de
+"regfish.de" "http://dyndns.regfish.de/?fqdn=[DOMAIN]&forcehost=1&authtype=secure&token=[PASSWORD]&ipv6=[IP]" "success|100|101"
+