aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorChristian Lachner <gladiac@gmail.com>2018-03-07 22:38:52 +0100
committerChristian Lachner <gladiac@gmail.com>2018-03-07 22:38:52 +0100
commit385eeba4c0e5143f9cbc2a4e6d9715ed060c9075 (patch)
treed79280b8192265687db3993050c0c76687c0a1c3 /net
parentd6ff6a97d5e4c29a8e16e51eb76244b2312db4c2 (diff)
haproxy: Fix Lua-support for mips(el)
- TARGET_CFLAGS were missing for haproxy which caused issue #4606 (https://github.com/openwrt/packages/issues/4606) - All targets finally have Lua support again Signed-off-by: Christian Lachner <gladiac@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/haproxy/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index e5d124b97..da0b3c474 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -94,13 +94,6 @@ endef
ENABLE_LUA:=y
ENABLE_REGPARM:=n
-ifeq ($(CONFIG_mips),y)
- ENABLE_LUA:=n
-endif
-ifeq ($(CONFIG_mipsel),y)
- ENABLE_LUA:=n
-endif
-
ifeq ($(CONFIG_TARGET_x86),y)
ENABLE_REGPARM:=y
endif
@@ -152,6 +145,7 @@ define Build/Compile
USE_ZLIB=yes USE_PCRE=1 USE_PCRE_JIT=1 USE_GETADDRINFO=1 \
VERSION="$(PKG_VERSION)-patch$(PKG_RELEASE)" \
$(ADDON) \
+ CFLAGS="$(TARGET_CFLAGS)" \
LD="$(TARGET_CC)" \
LDFLAGS="$(TARGET_LDFLAGS) -latomic" \
IGNOREGIT=1