aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.ca>2023-09-16 16:43:31 -0700
committerGitHub <noreply@github.com>2023-09-16 16:43:31 -0700
commit3653eb3d4a7d43f8f27f97d6475e84123837ced8 (patch)
treefb7489a79a03a005c171fa9477a35b879b492542 /net
parent75064f1bf7fb139084b5a8bde805b02c311b58e9 (diff)
parentbce310bfcd41a20b85fbe85fdcdf47ab1d5032bf (diff)
Merge pull request #22118 from stangri/master-adblock-fast
adblock-fast: bugfix: remove domains on allow
Diffstat (limited to 'net')
-rw-r--r--net/adblock-fast/Makefile2
-rwxr-xr-xnet/adblock-fast/files/etc/init.d/adblock-fast2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/adblock-fast/Makefile b/net/adblock-fast/Makefile
index 422b95c1e..317a3d1aa 100644
--- a/net/adblock-fast/Makefile
+++ b/net/adblock-fast/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=adblock-fast
PKG_VERSION:=1.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
PKG_LICENSE:=GPL-3.0-or-later
diff --git a/net/adblock-fast/files/etc/init.d/adblock-fast b/net/adblock-fast/files/etc/init.d/adblock-fast
index f7fb5b3d2..2a75e6938 100755
--- a/net/adblock-fast/files/etc/init.d/adblock-fast
+++ b/net/adblock-fast/files/etc/init.d/adblock-fast
@@ -1124,7 +1124,7 @@ adb_allow() {
for c in $string; do
output 2 " $c "
hf="$(echo "$c" | sed 's/\./\\./g')"
- if sed -i "/(^|\.)${hf}$/d;" "$outputFile" && \
+ if sed -i "/\(^\|\.\)${hf}$/d;" "$outputFile" && \
uci_add_list_if_new "${packageName}" 'config' 'allowed_domain' "$c"; then
output_ok
else