aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorNuno Goncalves <nunojpg@gmail.com>2015-07-13 01:26:47 +0100
committerNuno Goncalves <nunojpg@gmail.com>2015-07-13 02:30:12 +0100
commit35ddbb01b6896c103c3c559dc8d9a06750714d5b (patch)
tree3ca155347e0a26efee3c9ab163f0efc124817136 /net
parentd58ddeb6b638c43d0a6383672e34ccbcad3c74d2 (diff)
ntripcaster: change source server, fix install location
ntripcaster developer agency (http://igs.bkg.bund.de/) no longer provides sources for download. Created a github repository to provide sources and allow contributions. Fixed install location for configuration files. Signed-off-by: Nuno Goncalves <nunojpg@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/ntripcaster/Makefile31
1 files changed, 14 insertions, 17 deletions
diff --git a/net/ntripcaster/Makefile b/net/ntripcaster/Makefile
index 3941e2fc0..7828a25ca 100644
--- a/net/ntripcaster/Makefile
+++ b/net/ntripcaster/Makefile
@@ -10,12 +10,16 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ntripcaster
PKG_VERSION:=0.1.5
-PKG_RELEASE:=1
-PKG_LICENSE:=GPL-2.0+
-PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).zip
-PKG_SOURCE_URL:=http://igs.bkg.bund.de/root_ftp/NTRIP/software/
-PKG_MD5SUM:=8c85a6c31d8c5cdf2638fe103207a1fd
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/nunojpg/ntripcaster.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=03878920195cf854b38a1ea424f1cae57353fa87
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+
+PKG_LICENSE:=GPL-2.0+
PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
@@ -34,19 +38,12 @@ define Package/ntripcaster/description
BKG Standard Ntrip Broadcaster
endef
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
- unzip $(DL_DIR)/$(PKG_SOURCE) -d $(PKG_BUILD_DIR)
- mv $(PKG_BUILD_DIR)/$(PKG_NAME)$(PKG_VERSION)/* $(PKG_BUILD_DIR)
- chmod +x $(PKG_BUILD_DIR)/configure
-endef
-
define Package/ntripcaster/install
- $(INSTALL_DIR) $(1)/usr/local/ntripcaster/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ntripcaster $(1)/usr/local/ntripcaster/bin/
- $(INSTALL_DIR) $(1)/usr/local/ntripcaster/conf
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/conf/ntripcaster.conf.dist $(1)/usr/local/ntripcaster/conf/
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/conf/sourcetable.dat.dist $(1)/usr/local/ntripcaster/conf/
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ntripcaster $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/usr/share/ntripcaster/conf
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/conf/ntripcaster.conf.dist $(1)/usr/share/ntripcaster/conf/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/conf/sourcetable.dat.dist $(1)/usr/share/ntripcaster/conf/
endef
$(eval $(call BuildPackage,ntripcaster))