aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorTiago Gaspar <tiagogaspar8@gmail.com>2023-07-02 18:14:10 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-07-05 21:27:16 +0200
commit34e73bddab3dc22d0f2d9efc634f947e0232a51c (patch)
tree396a894cae143c4eac5d9c71aa7e2914a2208473 /net
parentf2c0fa9206463ef636a00216ef00fb5583c1d608 (diff)
nginx: add quic modue
This commit adds support for http/3. This is an experimental version and isn't fully supported because nginx is being built with the regular OpenSSL and the regular one doesn't support quic. Signed-off-by: Tiago Gaspar <tiagogaspar8@gmail.com>
Diffstat (limited to 'net')
2 files changed, 7 insertions, 0 deletions
diff --git a/net/nginx/Config_ssl.in b/net/nginx/Config_ssl.in
index fbfb64ae7..990a01e81 100644
--- a/net/nginx/Config_ssl.in
+++ b/net/nginx/Config_ssl.in
@@ -175,6 +175,11 @@ config NGINX_HTTP_V2
prompt "Enable HTTP_V2 module"
default y
+config NGINX_HTTP_QUIC
+ bool
+ prompt "Enable QUIC support"
+ default n
+
config NGINX_PCRE
bool
prompt "Enable PCRE library usage"
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index b90f55d0a..5c162a3bc 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -76,6 +76,7 @@ PKG_CONFIG_DEPENDS := \
CONFIG_NGINX_HTTP_UPSTREAM_ZONE \
CONFIG_NGINX_HTTP_CACHE \
CONFIG_NGINX_HTTP_V2 \
+ CONFIG_NGINX_HTTP_QUIC \
CONFIG_NGINX_PCRE \
CONFIG_NGINX_HTTP_REAL_IP \
CONFIG_NGINX_HTTP_SECURE_LINK \
@@ -401,6 +402,7 @@ CONFIGURE_ARGS += \
$(if $(call IsEnabled,NGINX_FLV),--with-http_flv_module) \
$(if $(call IsEnabled,NGINX_DAV),--with-http_dav_module) \
$(if $(call IsEnabled,NGINX_HTTP_AUTH_REQUEST),--with-http_auth_request_module) \
+ $(if $(call IsEnabled,NGINX_HTTP_QUIC),--with-http_v3_module) \
$(if $(call IsEnabled,NGINX_HTTP_V2),--with-http_v2_module) \
$(if $(call IsEnabled,NGINX_HTTP_REAL_IP),--with-http_realip_module) \
$(if $(call IsEnabled,NGINX_HTTP_SECURE_LINK),--with-http_secure_link_module) \