aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorWilliam Fleurant <meshnet@protonmail.com>2019-10-26 13:41:13 -0400
committerWilliam Fleurant <meshnet@protonmail.com>2019-10-26 14:13:47 -0400
commit2baab77b77c3db5cb8bb61e5697373e5b8e9ac58 (patch)
tree9c2ded399303fae9fff2961386709f579b29ed22 /net
parente4aa95eb6dd9590806e21af7f2f21b917d750221 (diff)
yggdrasil: uci firewall Section name and cover both IP versions
- rename the section instance to yggdrasil (feat. request) - allow zone to cover both ip4 and ip6 fam Signed-off-by: William Fleurant <meshnet@protonmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/yggdrasil/Makefile2
-rw-r--r--net/yggdrasil/files/yggdrasil.defaults15
2 files changed, 8 insertions, 9 deletions
diff --git a/net/yggdrasil/Makefile b/net/yggdrasil/Makefile
index 5234af1b6..6e268d310 100644
--- a/net/yggdrasil/Makefile
+++ b/net/yggdrasil/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=yggdrasil
PKG_VERSION:=0.3.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/yggdrasil-network/yggdrasil-go/tar.gz/v$(PKG_VERSION)?
diff --git a/net/yggdrasil/files/yggdrasil.defaults b/net/yggdrasil/files/yggdrasil.defaults
index 368750013..d5076cf6d 100644
--- a/net/yggdrasil/files/yggdrasil.defaults
+++ b/net/yggdrasil/files/yggdrasil.defaults
@@ -41,14 +41,13 @@ EOF
# create the firewall zone
uci -q batch <<-EOF >/dev/null
- add firewall zone
- set firewall.@zone[-1].name=yggdrasil
- add_list firewall.@zone[-1].network=yggdrasil
- set firewall.@zone[-1].input=REJECT
- set firewall.@zone[-1].output=ACCEPT
- set firewall.@zone[-1].forward=REJECT
- set firewall.@zone[-1].conntrack=1
- set firewall.@zone[-1].family=ipv6
+ set firewall.yggdrasil=zone
+ set firewall.yggdrasil.name=yggdrasil
+ add_list firewall.yggdrasil.network=yggdrasil
+ set firewall.yggdrasil.input=REJECT
+ set firewall.yggdrasil.output=ACCEPT
+ set firewall.yggdrasil.forward=REJECT
+ set firewall.yggdrasil.conntrack=1
EOF
# allow ICMP from yggdrasil zone, e.g. ping6