aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMichal Vasilek <michal.vasilek@nic.cz>2021-10-15 00:27:35 +0200
committerMichal Vasilek <michal.vasilek@nic.cz>2021-10-15 01:02:16 +0200
commit2b3b2ffe42cab96504e4e56683317ff1cb6dc4f6 (patch)
tree2da99774b40b8969b8d23c06e4add9156f582230 /net
parentb22aa5b9e6da092786bce8c90100b728ed053502 (diff)
knot-resolver: update to 5.4.2
* refresh patches * disabling kres_gen_test is not required anymore for cross compilation, it was fixed upstream with the 5.4.1 release Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
Diffstat (limited to 'net')
2 files changed, 3 insertions, 5 deletions
diff --git a/net/knot-resolver/Makefile b/net/knot-resolver/Makefile
index 23d6f4423..ca96f48c6 100644
--- a/net/knot-resolver/Makefile
+++ b/net/knot-resolver/Makefile
@@ -10,12 +10,12 @@ PKG_RELRO_FULL:=0
include $(TOPDIR)/rules.mk
PKG_NAME:=knot-resolver
-PKG_VERSION:=5.4.0
+PKG_VERSION:=5.4.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-resolver
-PKG_HASH:=534af671b98433b23b57039acc9d7d3c100a4888a8cf9aeba36161774ca0815e
+PKG_HASH:=ea6a219571a752056669bae3f2c0c3ed0bec58af5ab832d505a3ec9c4063a58b
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
PKG_LICENSE:=GPL-3.0-later
@@ -56,7 +56,6 @@ define Package/knot-resolver/config
source "$(SOURCE)/Config.in"
endef
-# kres_gen_test breaks on cross, fix is already upstream
MESON_ARGS+= \
$(if $(CONFIG_PACKAGE_knot-resolver_dnstap), -Ddnstap=enabled,-Ddnstap=disabled) \
-Dcapng=disabled \
@@ -69,7 +68,6 @@ MESON_ARGS+= \
-Dkeyfile_default=/etc/knot-resolver/root.keys \
-Dprefix=/usr \
-Dunit_tests=disabled \
- -Dkres_gen_test=false \
-Dutils=disabled
define Package/knot-resolver/install
diff --git a/net/knot-resolver/patches/030-fix-policy-hack.patch b/net/knot-resolver/patches/030-fix-policy-hack.patch
index 88f5c06d1..f7d46bafd 100644
--- a/net/knot-resolver/patches/030-fix-policy-hack.patch
+++ b/net/knot-resolver/patches/030-fix-policy-hack.patch
@@ -2,7 +2,7 @@ This patch fixes the problem with forwarding in knot-resolver v4.3.0.
It reintroduces a fix which enables policy related hack (knot/knot-resolver#205 (comment 94566) )
--- a/modules/policy/policy.lua
+++ b/modules/policy/policy.lua
-@@ -984,7 +984,7 @@ policy.layer = {
+@@ -1000,7 +1000,7 @@ policy.layer = {
if bit.band(state, bit.bor(kres.FAIL, kres.DONE)) ~= 0 then return state end
local qry = req:initial() -- same as :current() but more descriptive
return policy.evaluate(policy.rules, req, qry, state)