aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2019-07-17 03:34:31 -0300
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>2019-07-17 03:37:12 -0300
commit2a91500cb5cd7ec12682959712e45373b09a97f2 (patch)
tree777202aaf0fdf19d6eacc05d7b027544fee97a29 /net
parentc02fd073819a8c4e52d03f56b6b017f856e32c8e (diff)
trafficshaper: metadata and makefile cleanup
This results in minor metadata changes (spaces). No need to bump release. Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/trafficshaper/Makefile34
-rw-r--r--net/trafficshaper/files/trafficshaper.conf (renamed from net/trafficshaper/files/etc/config/trafficshaper)0
-rwxr-xr-xnet/trafficshaper/files/trafficshaper.init (renamed from net/trafficshaper/files/etc/init.d/trafficshaper)0
3 files changed, 16 insertions, 18 deletions
diff --git a/net/trafficshaper/Makefile b/net/trafficshaper/Makefile
index 939c37a97..cedf29479 100644
--- a/net/trafficshaper/Makefile
+++ b/net/trafficshaper/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2018 Luiz Angelo Daros de Luca
+# Copyright (C) 2018-2019 Luiz Angelo Daros de Luca
#
# This is free software, licensed under the GNU General Public License v2.
#
@@ -10,30 +10,25 @@ PKG_NAME:=trafficshaper
PKG_VERSION:=1.0.0
PKG_RELEASE:=1
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
-PKG_LICENSE:=GPLv2
-PKG_ARCH:=all
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-include $(INCLUDE_DIR)/package.mk
+PKG_LICENSE:=GPL-2.0-or-later
include $(INCLUDE_DIR)/package.mk
define Package/trafficshaper
- SECTION:=net
- CATEGORY:=Network
- DEPENDS:=+tc +kmod-sched-core +kmod-sched-connmark +kmod-ifb +iptables +kmod-sched-cake +iptables-mod-conntrack-extra
- TITLE:=WAN traffic shaper based on LAN addresses
- MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
- PKGARCH:=all
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=WAN traffic shaper based on LAN addresses
+ DEPENDS:=+tc +kmod-sched-core +kmod-sched-connmark +kmod-ifb +iptables +kmod-sched-cake +iptables-mod-conntrack-extra
+ PKGARCH:=all
endef
define Package/trafficshaper/description
-Setup QoS rules to limit (or reserve) traffic used by classes of clients.
-Uplink and downlink can be controled (or not controlled) independently.
-Client classes are defined by its network addresses (IPv4 or IPv6). Each
-client class can define absolute or relative (to wan) bandwith, and also
-the use (or not) of spare wan bandwidth when avaiable.
-
+ Setup QoS rules to limit (or reserve) traffic used by classes of clients.
+ Uplink and downlink can be controled (or not controlled) independently.
+ Client classes are defined by its network addresses (IPv4 or IPv6). Each
+ client class can define absolute or relative (to wan) bandwith, and also
+ the use (or not) of spare wan bandwidth when avaiable.
endef
define Package/trafficshaper/conffiles
@@ -44,7 +39,10 @@ define Build/Compile
endef
define Package/trafficshaper/install
-$(CP) ./files/* $(1)
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_CONF) ./files/trafficshaper.conf $(1)/etc/config/trafficshaper
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/trafficshaper.init $(1)/etc/init.d/trafficshaper
endef
$(eval $(call BuildPackage,trafficshaper))
diff --git a/net/trafficshaper/files/etc/config/trafficshaper b/net/trafficshaper/files/trafficshaper.conf
index daee10332..daee10332 100644
--- a/net/trafficshaper/files/etc/config/trafficshaper
+++ b/net/trafficshaper/files/trafficshaper.conf
diff --git a/net/trafficshaper/files/etc/init.d/trafficshaper b/net/trafficshaper/files/trafficshaper.init
index 445f50e38..445f50e38 100755
--- a/net/trafficshaper/files/etc/init.d/trafficshaper
+++ b/net/trafficshaper/files/trafficshaper.init