aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-10-19 23:26:00 -0700
committerRosen Penev <rosenp@gmail.com>2021-10-22 18:14:36 -0700
commit23b5b516ae6656e27f96813538d7baf40960722a (patch)
tree6697db8cd2b237cd5008eb907a4046d618a1a7ff /net
parentb6cd3125578a166998e28e9bd483d1f9ceb6b17e (diff)
gnunet: fix compilation with big endian
if is in the wrong spot. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/gnunet/patches/010-endian.patch18
-rw-r--r--net/gnunet/patches/100-fix-opus-and-pulse-library-detection.patch4
2 files changed, 20 insertions, 2 deletions
diff --git a/net/gnunet/patches/010-endian.patch b/net/gnunet/patches/010-endian.patch
new file mode 100644
index 000000000..4a956f14b
--- /dev/null
+++ b/net/gnunet/patches/010-endian.patch
@@ -0,0 +1,18 @@
+--- a/src/include/gnunet_common.h
++++ b/src/include/gnunet_common.h
+@@ -142,7 +142,6 @@ enum GNUNET_GenericReturnValue
+ * Endian operations
+ */
+
+-#if __BYTE_ORDER == __LITTLE_ENDIAN
+ #if defined(__linux__)
+ #define BYTE_SWAP_16(x) __bswap_16 (x)
+ #define BYTE_SWAP_32(x) __bswap_32 (x)
+@@ -162,6 +161,7 @@ enum GNUNET_GenericReturnValue
+ 56))
+ #endif
+
++#if __BYTE_ORDER == __LITTLE_ENDIAN
+ #define GNUNET_htobe16(x) BYTE_SWAP_16 (x)
+ #define GNUNET_htole16(x) (x)
+ #define GNUNET_be16toh(x) BYTE_SWAP_16 (x)
diff --git a/net/gnunet/patches/100-fix-opus-and-pulse-library-detection.patch b/net/gnunet/patches/100-fix-opus-and-pulse-library-detection.patch
index ee416ea72..0e40bb4ed 100644
--- a/net/gnunet/patches/100-fix-opus-and-pulse-library-detection.patch
+++ b/net/gnunet/patches/100-fix-opus-and-pulse-library-detection.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -813,10 +813,12 @@ AC_ARG_WITH(libpulse,
+@@ -851,10 +851,12 @@ AC_ARG_WITH(libpulse,
LDFLAGS="-L$with_libpulse/lib $LDFLAGS"
CPPFLAGS="-I$with_libpulse/include $CPPFLAGS"
AC_CHECK_HEADERS(pulse/simple.h,
@@ -17,7 +17,7 @@
])
],
[AC_MSG_RESULT([--with-libpulse not specified])
-@@ -856,10 +858,12 @@ AC_ARG_WITH(libopus,
+@@ -894,10 +896,12 @@ AC_ARG_WITH(libopus,
LDFLAGS="-L$with_libopus/lib $LDFLAGS"
CPPFLAGS="-I$with_libopus/include $CPPFLAGS"
AC_CHECK_HEADERS(opus/opus.h,