aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-06-15 01:46:21 -0700
committerGitHub <noreply@github.com>2021-06-15 01:46:21 -0700
commit237397d3af378dc33b554a316e6560305724aa8f (patch)
tree5c57850d84cb1108394263cf76397ef1587203eb /net
parentaefabac1267345539387d6a8135d9ca64d53f4dd (diff)
parent63b7febf5f62a120539611b1f7c252db5dc244cb (diff)
Merge pull request #15847 from neheb/assh
autossh: fix compilation without ssh installed
Diffstat (limited to 'net')
1 files changed, 3 insertions, 7 deletions
diff --git a/net/autossh/Makefile b/net/autossh/Makefile
index 78dc90eca..87fd91347 100644
--- a/net/autossh/Makefile
+++ b/net/autossh/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=autossh
PKG_VERSION:=1.4g
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://www.harding.motd.ca/autossh/
@@ -27,12 +27,8 @@ define Package/autossh
SUBMENU:=SSH
endef
-define Build/Compile
- $(call Build/Compile/Default, -f Makefile \
- CFLAGS="$(TARGET_CFLAGS) -Wall -D\"SSH_PATH=\\\"\$$$$(SSH)\\\"\" -D\"VER=\\\"\$$$$(VER)\\\"\"" \
- all \
- )
-endef
+CONFIGURE_VARS += \
+ ac_cv_path_ssh=/usr/bin/ssh
define Package/autossh/install
$(INSTALL_DIR) $(1)/usr/sbin