aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>2015-01-25 14:13:30 +0100
committerNikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>2015-01-25 14:13:30 +0100
commit2201c608f29dbc3577943c6dc571652797b36d3f (patch)
tree40a8d303d7095f744cf7926e68fee28a22171a6c /net
parent317ccf4d72f8eaba444063fc11a5ee4107580e60 (diff)
parenteeec3dcb4b779d53c95c28d9c49c5b30b965bcb2 (diff)
Merge pull request #818 from probonopd/announce
announce: Announce services on the network with Zeroconf/Bonjour
Diffstat (limited to 'net')
-rw-r--r--net/announce/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/net/announce/Makefile b/net/announce/Makefile
new file mode 100644
index 000000000..d2c17dad1
--- /dev/null
+++ b/net/announce/Makefile
@@ -0,0 +1,57 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=announce
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=src/LICENSE.txt
+PKG_MAINTAINER:=Simon Peter <probono@puredarwin.org>
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/probonopd/announce.git
+PKG_SOURCE_VERSION:=70d70f998686199deaa5d62b54688c869e237eef
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION)
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_BUILD_DEPENDS:= +libpthread
+
+define Package/announce
+ SECTION:=net
+ CATEGORY:=Network
+ SUBMENU:=IP Addresses and Names
+ TITLE:=Announce services on the network with Zeroconf/Bonjour
+ URL:=https://github.com/probonopd/announce
+ DEPENDS:= +libpthread
+endef
+
+define Package/announce/description
+ Announce services on the network with Zeroconf/Bonjour.
+ This announces services such as ssh, sftp, and http running on the local machine
+ to the network.
+endef
+
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ $(CP) $(PKG_BUILD_DIR)/src/* $(PKG_BUILD_DIR)/
+endef
+
+define Package/announce/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/announce $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/announce.initscript $(1)/etc/init.d/announce
+endef
+
+$(eval $(call BuildPackage,announce))