aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorTeleostNaCl Dai <teleostnacl@gmail.com>2024-04-26 15:59:12 +0800
committerTianling Shen <cnsztl@gmail.com>2024-05-03 13:55:13 +0800
commit206aa14ff30bde6204aa3f82a4b60fa0be4bb998 (patch)
tree24cbe6b81d69b9fd56b6360ba604aeeb7a4469df /net
parent6a4fb172dc5b06221405a3702f8126632ecf0028 (diff)
speedtest-go: add new package
This is a Command Line Interface (CLI) and pure Go API to test internet speed using speedtest.net. Its upstream is https://github.com/showwin/speedtest-go Signed-off-by: TeleostNaCl Dai <teleostnacl@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/speedtest-go/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/net/speedtest-go/Makefile b/net/speedtest-go/Makefile
new file mode 100644
index 000000000..9c53d9e7d
--- /dev/null
+++ b/net/speedtest-go/Makefile
@@ -0,0 +1,42 @@
+# SPDX-License-Identifier: GPL-3.0-only
+#
+# Copyright (C) 2021 ImmortalWrt.org
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=speedtest-go
+PKG_VERSION:=1.6.11
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/showwin/speedtest-go/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=e09e1532bf3d1d78cad6546e8614e72e818fb14c3a7c11d609905c9ae7337930
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=TeleostNaCl Dai <teleostnacl@gmail.com>
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+PKG_BUILD_FLAGS:=no-mips16
+
+GO_PKG:=github.com/showwin/speedtest-go
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/golang/golang-package.mk
+
+define Package/speedtest-go
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Test Internet Speed
+ URL:=https://github.com/showwin/speedtest-go
+ DEPENDS:=$(GO_ARCH_DEPENDS) +ca-bundle
+endef
+
+define Package/speedtest-go/description
+ Command Line Interface and pure Go API to
+ Test Internet Speed using speedtest.net
+endef
+
+$(eval $(call GoBinPackage,speedtest-go))
+$(eval $(call BuildPackage,speedtest-go))