aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2023-03-12 18:27:50 -0600
committerGitHub <noreply@github.com>2023-03-12 18:27:50 -0600
commit1dfb13eaebfe2907cdf48bd2053bc0bd7919a42f (patch)
treee61cc9793bef1e6ecab08d6e9618416fa493ba73 /net
parent96d2610994d4bb40c9ef8a63305ba1a97b6988af (diff)
parentae0a8072d6f51076c5b2e38ef645e4b3431ce7b5 (diff)
Merge pull request #20261 from pprindeville/strongswan-update-5.9.9
strongswan: Update to 5.9.9
Diffstat (limited to 'net')
-rw-r--r--net/strongswan/Makefile6
-rw-r--r--net/strongswan/patches/0905-undef-wolfssl-RNG.patch12
2 files changed, 15 insertions, 3 deletions
diff --git a/net/strongswan/Makefile b/net/strongswan/Makefile
index 35cf0fec1..cab4f5892 100644
--- a/net/strongswan/Makefile
+++ b/net/strongswan/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=strongswan
-PKG_VERSION:=5.9.8
-PKG_RELEASE:=5
+PKG_VERSION:=5.9.9
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
-PKG_HASH:=d3303a43c0bd7b75a12b64855e8edcb53696f06190364f26d1533bde1f2e453c
+PKG_HASH:=5e16580998834658c17cebfb31dd637e728669cf2fdd325460234a4643b8d81d
PKG_LICENSE:=GPL-2.0-or-later
PKG_MAINTAINER:=Philip Prindeville <philipp@redfish-solutions.com>, Noel Kuntze <noel.kuntze@thermi.consulting>
PKG_CPE_ID:=cpe:/a:strongswan:strongswan
diff --git a/net/strongswan/patches/0905-undef-wolfssl-RNG.patch b/net/strongswan/patches/0905-undef-wolfssl-RNG.patch
new file mode 100644
index 000000000..dfca722c9
--- /dev/null
+++ b/net/strongswan/patches/0905-undef-wolfssl-RNG.patch
@@ -0,0 +1,12 @@
+--- a/src/libstrongswan/plugins/wolfssl/wolfssl_plugin.c
++++ b/src/libstrongswan/plugins/wolfssl/wolfssl_plugin.c
+@@ -50,6 +50,9 @@
+ #ifndef FIPS_MODE
+ #define FIPS_MODE 0
+ #endif
++#ifdef RNG
++#undef RNG
++#endif
+
+ typedef struct private_wolfssl_plugin_t private_wolfssl_plugin_t;
+