aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2022-10-08 04:00:50 +0200
committerGitHub <noreply@github.com>2022-10-08 04:00:50 +0200
commit193ffa68c18e8624f61d992f9def449d2febe9f5 (patch)
tree74dc70801ef2970d89205ab8970b7e2d7b0f1684 /net
parent56627992fa557a0d1405cc7db807c4f4272a6b0b (diff)
parente4dfee088637d5ac71d4709325038c6fa7f1d297 (diff)
Merge pull request #19529 from blocktrron/qcsuper
qcsuper: add Package w/ necessary dependencies
Diffstat (limited to 'net')
-rw-r--r--net/qcsuper/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/net/qcsuper/Makefile b/net/qcsuper/Makefile
new file mode 100644
index 000000000..2bff07879
--- /dev/null
+++ b/net/qcsuper/Makefile
@@ -0,0 +1,58 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=qcsuper
+PKG_VERSION:=2022-08-11
+PKG_RELEASE:=$(AUTORELEASE)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/P1sec/QCSuper.git
+PKG_SOURCE_VERSION:=5c4e5295bf336bcce63c8ad7112ac04dee4b04fd
+PKG_MIRROR_HASH:=45ec6f839945f3c3cbd21ca973f3df2e8972113e32995bf5435403eea6872596
+
+PKG_MAINTAINER:=David Bauer <mail@david-bauer.net>
+PKG_LICENSE:=GPL-3.0
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/qcsuper
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+python3-light +python3-pyserial +python3-crcmod +python3-ctypes +python3-pycrate +python3-logging +python3-urllib
+ TITLE:=QCSuper
+ URL:=https://github.com/P1sec/QCSuper
+endef
+
+define Package/qcsuper/description
+QCSuper is a tool communicating with Qualcomm-based modems,
+allowing to capture raw 2G/3G/4G radio frames, among other things.
+
+It will allow you to generate PCAP captures of it using an USB dongle
+or an existing capture in another format.
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/qcsuper/install
+ $(INSTALL_DIR) $(1)/usr/lib/qcsuper/inputs $(1)/usr/lib/qcsuper/modules $(1)/usr/lib/qcsuper/protocol $(1)/usr/bin
+
+ $(CP) $(PKG_BUILD_DIR)/inputs/* $(1)/usr/lib/qcsuper/inputs/
+ $(RM) -rf $(1)/usr/lib/qcsuper/inputs/external
+ $(RM) -rf $(1)/usr/lib/qcsuper/inputs/adb_bridge
+ $(RM) -rf $(1)/usr/lib/qcsuper/inputs/adb_wsl2_bridge
+
+ $(CP) $(PKG_BUILD_DIR)/modules/* $(1)/usr/lib/qcsuper/modules/
+
+ $(CP) $(PKG_BUILD_DIR)/protocol/* $(1)/usr/lib/qcsuper/protocol/
+
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/qcsuper.py $(1)/usr/lib/qcsuper/
+ $(LN) /usr/lib/qcsuper/qcsuper.py $(1)/usr/bin/qcsuper
+endef
+
+$(eval $(call BuildPackage,qcsuper))