aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAndy Walsh <andy.walsh44+github@gmail.com>2018-08-04 21:20:22 +0200
committerYousong Zhou <yszhou4tech@gmail.com>2018-08-06 09:50:54 +0800
commit18e9a8b479699e8642ebd46f813378b3efdc0650 (patch)
treedd9ea4cb9e0e19901134507d7424dbf80448d864 /net
parent797a003f3ce0d197f742aaa435c23e3c67438b83 (diff)
samba4: add missing avahi service definitions
Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/samba4/Makefile5
-rw-r--r--net/samba4/files/samba.service14
2 files changed, 19 insertions, 0 deletions
diff --git a/net/samba4/Makefile b/net/samba4/Makefile
index c140d7aa2..c111d0986 100644
--- a/net/samba4/Makefile
+++ b/net/samba4/Makefile
@@ -369,6 +369,10 @@ endif
ifeq ($(CONFIG_SAMBA4_SERVER_ACL),y)
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sharesec $(1)/usr/bin/
endif
+ifeq ($(CONFIG_SAMBA4_SERVER_AVAHI),y)
+ $(INSTALL_DIR) $(1)/etc/avahi/services
+ $(INSTALL_DATA) ./files/samba.service $(1)/etc/avahi/services/
+endif
$(INSTALL_DIR) $(1)/etc/config $(1)/etc/samba $(1)/etc/init.d
$(INSTALL_DATA) ./files/samba.config $(1)/etc/config/samba4
$(INSTALL_DATA) ./files/smb.conf.template $(1)/etc/samba
@@ -385,6 +389,7 @@ define Package/samba4-server/conffiles
/etc/samba/idmap.ldb
/etc/samba/lmhosts
/etc/nsswitch.conf
+/etc/avahi/services/samba.service
endef
$(eval $(call BuildPackage,samba4-libs))
diff --git a/net/samba4/files/samba.service b/net/samba4/files/samba.service
new file mode 100644
index 000000000..8191e527f
--- /dev/null
+++ b/net/samba4/files/samba.service
@@ -0,0 +1,14 @@
+<?xml version="1.0" standalone='no'?><!--*-nxml-*-->
+<!DOCTYPE service-group SYSTEM "avahi-service.dtd">
+<service-group>
+ <name replace-wildcards="yes">%h</name>
+ <service>
+ <type>_adisk._tcp</type>
+ <txt-record>sys=waMa=0,adVF=0x100</txt-record>
+ <txt-record>dk0=adVN=TimeMachine,adVF=0x82</txt-record>
+ </service>
+ <service>
+ <type>_smb._tcp</type>
+ <port>445</port>
+ </service>
+</service-group>