aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2015-05-28 17:05:56 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2015-05-28 17:05:56 +0200
commit17f428fca60b5b4204e64150f98a344e924fc555 (patch)
treecb34acb4559bab281135fc00a6a3340ce575a443 /net
parentfe3d554c6a9b3d0e572deca05acfbcf094687b04 (diff)
parent165fb918a6db3a91e70086d903deafb5c50c05a0 (diff)
Merge pull request #1292 from ffainelli/ethtool
ethtool: Add option to enable/disable pretty-printing
Diffstat (limited to 'net')
-rw-r--r--net/ethtool/Config.in7
-rw-r--r--net/ethtool/Makefile14
2 files changed, 20 insertions, 1 deletions
diff --git a/net/ethtool/Config.in b/net/ethtool/Config.in
new file mode 100644
index 000000000..7ec55536e
--- /dev/null
+++ b/net/ethtool/Config.in
@@ -0,0 +1,7 @@
+menu "Configuration"
+ depends on PACKAGE_ethtool
+
+ config ETHTOOL_PRETTY_DUMP
+ bool "Enable pretty printing"
+
+endmenu
diff --git a/net/ethtool/Makefile b/net/ethtool/Makefile
index 5ffb8253c..818a011ff 100644
--- a/net/ethtool/Makefile
+++ b/net/ethtool/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ethtool
PKG_VERSION:=3.18
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Matthias Schiffer <mschiffer@universe-factory.net>
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -23,6 +23,8 @@ PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
+PKG_CONFIG_DEPENDS:=ETHTOOL_PRETTY_DUMP
+
include $(INCLUDE_DIR)/package.mk
define Package/ethtool
@@ -37,6 +39,16 @@ define Package/ethtool/description
network interface
endef
+define Package/ethtool/config
+ source "$(SOURCE)/Config.in
+endef
+
+ifeq ($(CONFIG_ETHTOOL_PRETTY_DUMP),y)
+CONFIGURE_ARGS += --enable-pretty-dump
+else
+CONFIGURE_ARGS += --disable-pretty-dump
+endif
+
define Package/ethtool/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ethtool $(1)/usr/sbin