aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPeter Wagner <tripolar@gmx.at>2015-05-27 21:32:31 +0200
committerPeter Wagner <tripolar@gmx.at>2015-05-27 21:32:31 +0200
commit1710be86057dfa6ed748d3183b637dd65e651b76 (patch)
treec9ae9b281ad19b869e6aa1baa087b95de1ac8cb1 /net
parent9e2788c96bdb2900b140d69528d45e4e12a15f8a (diff)
git: update to 2.4.2
Signed-off-by: Peter Wagner <tripolar@gmx.at>
Diffstat (limited to 'net')
-rw-r--r--net/git/Makefile4
-rw-r--r--net/git/patches/100-convert_builtin.patch30
-rw-r--r--net/git/patches/400-imapsend_without_curl.patch2
3 files changed, 18 insertions, 18 deletions
diff --git a/net/git/Makefile b/net/git/Makefile
index 429d8e690..c088e722e 100644
--- a/net/git/Makefile
+++ b/net/git/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=git
-PKG_VERSION:=2.3.5
+PKG_VERSION:=2.4.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/scm/git/
-PKG_MD5SUM:=be8c0bbb0c5ee6ab7cdcffd2c9375fe6
+PKG_MD5SUM:=0b8dc818ed4766342978d744522aec49
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
diff --git a/net/git/patches/100-convert_builtin.patch b/net/git/patches/100-convert_builtin.patch
index 05a3f3f33..e3d42007d 100644
--- a/net/git/patches/100-convert_builtin.patch
+++ b/net/git/patches/100-convert_builtin.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -538,16 +538,7 @@ EXTRA_PROGRAMS =
+@@ -549,16 +549,7 @@ EXTRA_PROGRAMS =
# ... and all the rest that could be moved out of bindir to gitexecdir
PROGRAMS += $(EXTRA_PROGRAMS)
@@ -17,7 +17,7 @@
# Binary suffix, set to .exe for Windows builds
X =
-@@ -896,6 +887,11 @@ BUILTIN_OBJS += builtin/verify-commit.o
+@@ -907,6 +898,11 @@ BUILTIN_OBJS += builtin/verify-commit.o
BUILTIN_OBJS += builtin/verify-pack.o
BUILTIN_OBJS += builtin/verify-tag.o
BUILTIN_OBJS += builtin/write-tree.o
@@ -29,7 +29,7 @@
GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
EXTLIBS =
-@@ -1070,7 +1066,7 @@ endif
+@@ -1089,7 +1085,7 @@ endif
EXTLIBS += -lz
ifndef NO_OPENSSL
@@ -38,7 +38,7 @@
ifdef OPENSSLDIR
BASIC_CFLAGS += -I$(OPENSSLDIR)/include
OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
-@@ -1933,10 +1929,6 @@ endif
+@@ -1956,10 +1952,6 @@ endif
git-%$X: %.o GIT-LDFLAGS $(GITLIBS)
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
@@ -49,7 +49,7 @@
git-http-fetch$X: http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS)
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
$(LIBS) $(CURL_LIBCURL)
-@@ -2254,10 +2246,11 @@ endif
+@@ -2277,10 +2269,11 @@ endif
bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
{ test "$$bindir/" = "$$execdir/" || \
@@ -97,7 +97,7 @@
+#include "../upload-pack.c"
--- a/daemon.c
+++ b/daemon.c
-@@ -1193,7 +1193,7 @@ static int serve(struct string_list *lis
+@@ -1192,7 +1192,7 @@ static int serve(struct string_list *lis
return service_loop(&socklist);
}
@@ -106,7 +106,7 @@
{
int listen_port = 0;
struct string_list listen_addr = STRING_LIST_INIT_NODUP;
-@@ -1389,12 +1389,13 @@ int main(int argc, char **argv)
+@@ -1388,12 +1388,13 @@ int main(int argc, char **argv)
store_pid(pid_file);
/* prepare argv for serving-processes */
@@ -127,7 +127,7 @@
}
--- a/fast-import.c
+++ b/fast-import.c
-@@ -3354,7 +3354,7 @@ static void parse_argv(void)
+@@ -3351,7 +3351,7 @@ static void parse_argv(void)
read_marks();
}
@@ -138,7 +138,7 @@
--- a/git.c
+++ b/git.c
-@@ -309,11 +309,11 @@ static int handle_alias(int *argcp, cons
+@@ -311,11 +311,11 @@ static int handle_alias(int *argcp, cons
struct cmd_struct {
const char *cmd;
@@ -152,7 +152,7 @@
{
int status, help;
struct stat st;
-@@ -393,6 +393,7 @@ static struct cmd_struct commands[] = {
+@@ -395,6 +395,7 @@ static struct cmd_struct commands[] = {
{ "config", cmd_config, RUN_SETUP_GENTLY },
{ "count-objects", cmd_count_objects, RUN_SETUP },
{ "credential", cmd_credential, RUN_SETUP_GENTLY },
@@ -160,7 +160,7 @@
{ "describe", cmd_describe, RUN_SETUP },
{ "diff", cmd_diff },
{ "diff-files", cmd_diff_files, RUN_SETUP | NEED_WORK_TREE },
-@@ -411,6 +412,7 @@ static struct cmd_struct commands[] = {
+@@ -413,6 +414,7 @@ static struct cmd_struct commands[] = {
{ "grep", cmd_grep, RUN_SETUP_GENTLY },
{ "hash-object", cmd_hash_object },
{ "help", cmd_help },
@@ -168,7 +168,7 @@
{ "index-pack", cmd_index_pack, RUN_SETUP_GENTLY },
{ "init", cmd_init_db, NO_SETUP },
{ "init-db", cmd_init_db, NO_SETUP },
-@@ -459,6 +461,7 @@ static struct cmd_struct commands[] = {
+@@ -461,6 +463,7 @@ static struct cmd_struct commands[] = {
{ "revert", cmd_revert, RUN_SETUP | NEED_WORK_TREE },
{ "rm", cmd_rm, RUN_SETUP },
{ "send-pack", cmd_send_pack, RUN_SETUP },
@@ -176,7 +176,7 @@
{ "shortlog", cmd_shortlog, RUN_SETUP_GENTLY | USE_PAGER },
{ "show", cmd_show, RUN_SETUP },
{ "show-branch", cmd_show_branch, RUN_SETUP },
-@@ -475,6 +478,7 @@ static struct cmd_struct commands[] = {
+@@ -477,6 +480,7 @@ static struct cmd_struct commands[] = {
{ "update-server-info", cmd_update_server_info, RUN_SETUP },
{ "upload-archive", cmd_upload_archive },
{ "upload-archive--writer", cmd_upload_archive_writer },
@@ -186,7 +186,7 @@
{ "verify-pack", cmd_verify_pack },
--- a/imap-send.c
+++ b/imap-send.c
-@@ -1484,7 +1484,7 @@ static int curl_append_msgs_to_imap(stru
+@@ -1492,7 +1492,7 @@ static int curl_append_msgs_to_imap(stru
}
#endif
@@ -208,7 +208,7 @@
const char **user_argv;
--- a/upload-pack.c
+++ b/upload-pack.c
-@@ -793,7 +793,7 @@ static int upload_pack_config(const char
+@@ -797,7 +797,7 @@ static int upload_pack_config(const char
return parse_hide_refs_config(var, value, "uploadpack");
}
diff --git a/net/git/patches/400-imapsend_without_curl.patch b/net/git/patches/400-imapsend_without_curl.patch
index 44ceb013f..e96330c0e 100644
--- a/net/git/patches/400-imapsend_without_curl.patch
+++ b/net/git/patches/400-imapsend_without_curl.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -1039,7 +1039,7 @@ else
+@@ -1058,7 +1058,7 @@ else
endif
curl_check := $(shell (echo 072200; curl-config --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
ifeq "$(curl_check)" "072200"