aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2018-08-02 19:41:08 +0300
committerGitHub <noreply@github.com>2018-08-02 19:41:08 +0300
commit1709b83091ceb043be9b6056e73c64af213200de (patch)
treee4669a4c430c653001e31c42b145c35dd6e1da32 /net
parent78e3c2b1a96e5d662e7fbb3e1ad9c3dfab4d18b5 (diff)
parent8d446e8da68b92d6fb03fde362e44f64ea403671 (diff)
Merge pull request #5069 from dedeckeh/pr-netsnmp-fw
net-snmp: fix inbound firewall rule support
Diffstat (limited to 'net')
-rw-r--r--net/net-snmp/Makefile2
-rw-r--r--net/net-snmp/files/snmpd.init5
2 files changed, 6 insertions, 1 deletions
diff --git a/net/net-snmp/Makefile b/net/net-snmp/Makefile
index d3dda58f1..ecb4efa12 100644
--- a/net/net-snmp/Makefile
+++ b/net/net-snmp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=net-snmp
PKG_VERSION:=5.7.3
-PKG_RELEASE:=9
+PKG_RELEASE:=10
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/net-snmp
diff --git a/net/net-snmp/files/snmpd.init b/net/net-snmp/files/snmpd.init
index cce00b2de..9ebcb491c 100644
--- a/net/net-snmp/files/snmpd.init
+++ b/net/net-snmp/files/snmpd.init
@@ -338,6 +338,7 @@ start_service() {
stop_service() {
[ -f "$CONFIGFILE" ] && rm -f "$CONFIGFILE"
+ procd_set_config_changed firewall
}
service_triggers(){
@@ -350,3 +351,7 @@ service_triggers(){
procd_add_reload_trigger 'snmpd'
}
+
+service_started() {
+ procd_set_config_changed firewall
+}