aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2021-12-07 10:48:23 +0100
committerRosen Penev <rosenp@gmail.com>2021-12-07 12:24:03 -0800
commit10ab2306702c5292f98a43cf5a1dfc0b7ab99c27 (patch)
tree6bafce35d8600343bd7798585ef179506901d046 /net
parentf2f46497832ca4a146250a0a140abc05c75b2e6f (diff)
knot-resolver: update to version 5.4.3
Release notes: https://www.knot-resolver.cz/2021-12-01-knot-resolver-5.4.3.html Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/knot-resolver/Makefile4
-rw-r--r--net/knot-resolver/patches/030-fix-policy-hack.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/net/knot-resolver/Makefile b/net/knot-resolver/Makefile
index ca96f48c6..8e79db2a4 100644
--- a/net/knot-resolver/Makefile
+++ b/net/knot-resolver/Makefile
@@ -10,12 +10,12 @@ PKG_RELRO_FULL:=0
include $(TOPDIR)/rules.mk
PKG_NAME:=knot-resolver
-PKG_VERSION:=5.4.2
+PKG_VERSION:=5.4.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-resolver
-PKG_HASH:=ea6a219571a752056669bae3f2c0c3ed0bec58af5ab832d505a3ec9c4063a58b
+PKG_HASH:=488729eb93190336b6bca10de0d78ecb7919f77fcab105debc0a644aa7d0a506
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
PKG_LICENSE:=GPL-3.0-later
diff --git a/net/knot-resolver/patches/030-fix-policy-hack.patch b/net/knot-resolver/patches/030-fix-policy-hack.patch
index f7d46bafd..991dddd96 100644
--- a/net/knot-resolver/patches/030-fix-policy-hack.patch
+++ b/net/knot-resolver/patches/030-fix-policy-hack.patch
@@ -2,7 +2,7 @@ This patch fixes the problem with forwarding in knot-resolver v4.3.0.
It reintroduces a fix which enables policy related hack (knot/knot-resolver#205 (comment 94566) )
--- a/modules/policy/policy.lua
+++ b/modules/policy/policy.lua
-@@ -1000,7 +1000,7 @@ policy.layer = {
+@@ -1047,7 +1047,7 @@ policy.layer = {
if bit.band(state, bit.bor(kres.FAIL, kres.DONE)) ~= 0 then return state end
local qry = req:initial() -- same as :current() but more descriptive
return policy.evaluate(policy.rules, req, qry, state)