aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-16 15:41:19 -0700
committerRosen Penev <rosenp@gmail.com>2020-06-18 15:14:33 -0700
commit0df6c58f82f0b84ca08696d9d0760d425ce11917 (patch)
treeb07ef0514ea0fc2058d5c4140fd06f7e9ed2ab24 /net
parentd498a749109d84bd9a5874cc34638b08858eb243 (diff)
tor: remove libssp hack
Does not seem to be needed anymore. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/tor/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/net/tor/Makefile b/net/tor/Makefile
index 0bac41a3e..ee6e327cf 100644
--- a/net/tor/Makefile
+++ b/net/tor/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tor
PKG_VERSION:=0.4.3.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://dist.torproject.org/ \
@@ -103,18 +103,12 @@ CONFIGURE_ARGS += \
--disable-lzma \
--disable-zstd \
--with-tor-user=tor \
- --with-tor-group=tor
+ --with-tor-group=tor \
+ --with-pic
TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
TARGET_LDFLAGS += -Wl,--gc-sections -flto
-ifneq ($(CONFIG_SSP_SUPPORT),y)
- CONFIGURE_ARGS += \
- --disable-gcc-hardening
-else
- EXTRA_CFLAGS += $(FPIC)
-endif
-
CONFIGURE_VARS += \
CROSS_COMPILE="yes"