aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPeter Wagner <tripolar@gmx.at>2014-10-14 18:00:42 +0200
committerPeter Wagner <tripolar@gmx.at>2014-10-14 18:00:42 +0200
commit0d260899aa2585959d7a7f1e9273db61c21ea77f (patch)
treedb138d47dab3c2a22e0dac72811f73a2d6f045f1 /net
parentaf0003c3beded153f1d36c5a3d891e53de4ee6a2 (diff)
openssh,ntpd: move USERID to the server only as the client utils don't need a user/group
Signed-off-by: Peter Wagner <tripolar@gmx.at>
Diffstat (limited to 'net')
-rw-r--r--net/ntpd/Makefile3
-rw-r--r--net/openssh/Makefile5
2 files changed, 5 insertions, 3 deletions
diff --git a/net/ntpd/Makefile b/net/ntpd/Makefile
index 655902485..c78563509 100644
--- a/net/ntpd/Makefile
+++ b/net/ntpd/Makefile
@@ -31,7 +31,6 @@ define Package/ntpd/Default
MAINTAINER:=Peter Wagner <tripolar@gmx.at>
URL:=http://www.ntp.org/
DEPENDS:=+libcap
- USERID:=ntp=123:ntp=123
endef
define Package/ntpd/Default/description
@@ -44,6 +43,7 @@ define Package/ntpd
$(call Package/ntpd/Default)
TITLE+= server
VARIANT:=nossl
+ USERID:=ntp=123:ntp=123
endef
define Package/ntpd/description
@@ -57,6 +57,7 @@ $(call Package/ntpd/Default)
TITLE+= server (with OpenSSL support)
VARIANT:=ssl
DEPENDS+= +libopenssl
+ USERID:=ntp=123:ntp=123
endef
define Package/ntpd-ssl/description
diff --git a/net/openssh/Makefile b/net/openssh/Makefile
index f4f68bb03..ba4cb38c1 100644
--- a/net/openssh/Makefile
+++ b/net/openssh/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssh
PKG_VERSION:=6.6p1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
@@ -35,7 +35,6 @@ define Package/openssh/Default
URL:=http://www.openssh.com/
SUBMENU:=SSH
VARIANT:=without-pam
- USERID:=sshd=22:sshd=22
endef
define Package/openssh-moduli
@@ -84,6 +83,7 @@ define Package/openssh-server
$(call Package/openssh/Default)
DEPENDS+= +openssh-keygen
TITLE+= server
+ USERID:=sshd=22:sshd=22
endef
define Package/openssh-server/description
@@ -99,6 +99,7 @@ define Package/openssh-server-pam
DEPENDS+= +libpthread +openssh-keygen +libpam
TITLE+= server (with PAM support)
VARIANT:=with-pam
+ USERID:=sshd=22:sshd=22
endef
define Package/openssh-server-pam/description