aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-10 13:16:55 -0700
committerRosen Penev <rosenp@gmail.com>2020-08-10 15:25:04 -0700
commit0b37205d21f97adb7a17db65b7f1e816b84474e6 (patch)
treef06a0f5aefd01207a4a2c5ad0161f9cfb17b4dc4 /net
parent11c4323665df0e4d03ce2d843f0a52401f0e0a8e (diff)
knxd: fix compilation without sys/cdefs
sys/cdefs.h does not come with musl. It's also deprecated. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/knxd/Makefile2
-rw-r--r--net/knxd/patches/020-cdefs.patch25
2 files changed, 26 insertions, 1 deletions
diff --git a/net/knxd/Makefile b/net/knxd/Makefile
index 774062c68..e70085a0b 100644
--- a/net/knxd/Makefile
+++ b/net/knxd/Makefile
@@ -12,7 +12,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=knxd
PKG_VERSION:=0.14.39
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/knxd/knxd/tar.gz/$(PKG_VERSION)?
diff --git a/net/knxd/patches/020-cdefs.patch b/net/knxd/patches/020-cdefs.patch
new file mode 100644
index 000000000..d2924e266
--- /dev/null
+++ b/net/knxd/patches/020-cdefs.patch
@@ -0,0 +1,25 @@
+--- a/src/include/eibclient.h
++++ b/src/include/eibclient.h
+@@ -27,10 +27,11 @@
+ #ifndef EIBCLIENT_H
+ #define EIBCLIENT_H
+
+-#include <sys/cdefs.h>
+ #include <stdint.h>
+
+-__BEGIN_DECLS;
++#ifdef __cplusplus
++extern "C" {
++#endif
+
+ #include "eibloadresult.h"
+
+@@ -935,5 +936,7 @@ int EIB_Cache_LastUpdates2_async (EIBConnection * con, uint32_t start,
+ uint32_t * end);
+
+
+-__END_DECLS
++#ifdef __cplusplus
++}
++#endif
+ #endif