aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorVasileios Lakafosis <lakafosi@cisco.com>2014-09-29 15:38:51 -0700
committerVasileios Lakafosis <lakafosi@cisco.com>2014-09-29 15:38:51 -0700
commit0276a4733ebc81a3486c460238d36d214ae22d24 (patch)
treec6750abbfb71537fdbfbce9ec28775bdb79b2684 /net
parent832aa53af9cc940c19552511a13ed64db6c158b3 (diff)
lispmob: Update to 0.4.1
Signed-off-by: Vasileios Lakafosis <lakafosi@cisco.com>
Diffstat (limited to 'net')
-rw-r--r--net/lispmob/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/net/lispmob/Makefile b/net/lispmob/Makefile
new file mode 100644
index 000000000..4742deeb7
--- /dev/null
+++ b/net/lispmob/Makefile
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2012-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lispmob
+PKG_REV:=180aa39d338a00bb532e421de7f8513492cf2e8b
+PKG_VERSION:=0.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=git://github.com/LISPmob/lispmob.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/lispd/default
+ MAINTAINER:=Vasileios Lakafosis <lakafv@gmail.com>
+ URL:=http://lisp.cisco.com/
+endef
+
+define Package/lispd
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Locator/ID separation protocol (using TUN)
+ URL:=https://github.com/LISPmob
+ DEPENDS:= +librt +libopenssl +confuse +kmod-tun +uci +kmod-ipv6
+ $(call Package/lispd/default)
+endef
+
+define Package/lispd/description
+ This packet provides support for the Locator-ID Seperation Protocol.
+endef
+
+MAKE_FLAGS += \
+ platform=openwrt
+
+define Package/lispd/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/lispd/lispd $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/openWRT/lispd.uci.example $(1)/etc/config/lispd
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/openWRT/openwrt.init.script $(1)/etc/init.d/lisp
+endef
+
+$(eval $(call BuildPackage,lispd))