aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2019-11-18 09:28:48 +0100
committerGitHub <noreply@github.com>2019-11-18 09:28:48 +0100
commit0150459a78519c8a421a1ad8a164f0b22d74d0e6 (patch)
tree237d7810c537045e26266ef73946fe7b00231e38 /net
parentdf4811c6c33e81320d8980305ff63e7f850b1145 (diff)
parent6d638c3e23f66850cc8bd272b9fe5b9f11bec784 (diff)
Merge pull request #10538 from TDT-AG/pr/20191113-mwan3
mwan3: add https ping possibility and a minor fix
Diffstat (limited to 'net')
-rw-r--r--net/mwan3/Makefile6
-rw-r--r--net/mwan3/files/lib/mwan3/mwan3.sh2
-rwxr-xr-xnet/mwan3/files/usr/sbin/mwan3track9
3 files changed, 11 insertions, 6 deletions
diff --git a/net/mwan3/Makefile b/net/mwan3/Makefile
index cf37fc5b1..9815663fc 100644
--- a/net/mwan3/Makefile
+++ b/net/mwan3/Makefile
@@ -8,10 +8,10 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mwan3
-PKG_VERSION:=2.8.1
-PKG_RELEASE:=1
+PKG_VERSION:=2.8.2
+PKG_RELEASE:=2
PKG_MAINTAINER:=Florian Eckert <fe@dev.tdt.de>
-PKG_LICENSE:=GPLv2
+PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/net/mwan3/files/lib/mwan3/mwan3.sh b/net/mwan3/files/lib/mwan3/mwan3.sh
index ae7b398aa..88159e8b9 100644
--- a/net/mwan3/files/lib/mwan3/mwan3.sh
+++ b/net/mwan3/files/lib/mwan3/mwan3.sh
@@ -1004,7 +1004,7 @@ mwan3_set_user_iptables_rule()
case $proto in
tcp|udp)
[ "$global_logging" = "1" ] && [ "$rule_logging" = "1" ] && {
- $IPT -A mwan3_rules \
+ $IPT4 -A mwan3_rules \
-p $proto \
-s $src_ip \
-d $dest_ip $ipset \
diff --git a/net/mwan3/files/usr/sbin/mwan3track b/net/mwan3/files/usr/sbin/mwan3track
index 5a3692230..a88708f06 100755
--- a/net/mwan3/files/usr/sbin/mwan3track
+++ b/net/mwan3/files/usr/sbin/mwan3track
@@ -61,7 +61,7 @@ main() {
local recovery_interval down up size
local keep_failure_interval check_quality failure_latency
local recovery_latency failure_loss recovery_loss
- local max_ttl
+ local max_ttl httping_ssl
[ -z "$5" ] && echo "Error: should not be started manually" && exit 0
@@ -75,6 +75,7 @@ main() {
config_load mwan3
config_get track_method $1 track_method ping
+ config_get_bool httping_ssl $1 httping_ssl 0
validate_track_method $track_method $SRC_IP || {
track_method=ping
if validate_track_method $track_method; then
@@ -149,7 +150,11 @@ main() {
result=$?
;;
httping)
- httping -y $SRC_IP -c $count -t $timeout -q $track_ip &> /dev/null
+ if [ "$httping_ssl" -eq 1 ]; then
+ httping -y $SRC_IP -c $count -t $timeout -q "https://$track_ip" &> /dev/null
+ else
+ httping -y $SRC_IP -c $count -t $timeout -q "http://$track_ip" &> /dev/null
+ fi
result=$?
;;
nping-tcp)