aboutsummaryrefslogtreecommitdiff
path: root/net/znc/patches
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-06-11 17:46:09 -0700
committerJonas Gorski <jonas.gorski@gmail.com>2018-07-27 15:09:41 +0200
commitcb202c0acbc4b07847a7cd07e5f642f54dafad83 (patch)
tree76c55c222264c29a7cd63d1090cebf81a5577d9b /net/znc/patches
parent57c8664b31bb1b2c6fdf7256063ad7fca713ee52 (diff)
znc: Update to 1.7.1
Notable Changes: * New IRCv3.2 capabilities support on client and server side * Increased max line lengths * support for stripping color control codes * various bug fixes Signed-off-by: Rosen Penev <rosenp@gmail.com> [jonas.gorski: add notable changes, switch to 1.7.1] Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'net/znc/patches')
-rw-r--r--net/znc/patches/100-move_rootcheck_after_config.patch92
-rw-r--r--net/znc/patches/101-Reduce_rebuild_time.patch4
-rw-r--r--net/znc/patches/104-disable-empty-modules-check.patch24
3 files changed, 61 insertions, 59 deletions
diff --git a/net/znc/patches/100-move_rootcheck_after_config.patch b/net/znc/patches/100-move_rootcheck_after_config.patch
index 15ecdca47..6da68493d 100644
--- a/net/znc/patches/100-move_rootcheck_after_config.patch
+++ b/net/znc/patches/100-move_rootcheck_after_config.patch
@@ -1,52 +1,52 @@
-From adf42357c9043c38d9a9b47544a1b46445bdae19 Mon Sep 17 00:00:00 2001
-From: Jonas Gorski <jonas.gorski+openwrt@gmail.com>
-Date: Wed, 6 Apr 2011 04:10:23 +0200
-Subject: [PATCH] Move the root check to after config parsing
-
----
- src/main.cpp | 27 ++++++++++++++-------------
- 1 file changed, 14 insertions(+), 13 deletions(-)
-
+diff --git a/src/main.cpp b/src/main.cpp
+index 6ea10ec..0bf028b 100644
--- a/src/main.cpp
+++ b/src/main.cpp
-@@ -312,19 +312,6 @@ int main(int argc, char** argv) {
- CUtils::PrintStatus(true, "");
- }
+@@ -422,23 +422,6 @@ int main(int argc, char** argv) {
+ CUtils::PrintStatus(true, "");
+ }
-- if (isRoot()) {
-- CUtils::PrintError("You are running ZNC as root! Don't do that! There are not many valid");
-- CUtils::PrintError("reasons for this and it can, in theory, cause great damage!");
-- if (!bAllowRoot) {
-- CZNC::DestroyInstance();
-- return 1;
-- }
-- CUtils::PrintError("You have been warned.");
-- CUtils::PrintError("Hit CTRL+C now if you don't want to run ZNC as root.");
-- CUtils::PrintError("ZNC will start in 30 seconds.");
-- sleep(30);
-- }
+- if (isRoot()) {
+- CUtils::PrintError(
+- "You are running ZNC as root! Don't do that! There are not many "
+- "valid");
+- CUtils::PrintError(
+- "reasons for this and it can, in theory, cause great damage!");
+- if (!bAllowRoot) {
+- CZNC::DestroyInstance();
+- return 1;
+- }
+- CUtils::PrintError("You have been warned.");
+- CUtils::PrintError(
+- "Hit CTRL+C now if you don't want to run ZNC as root.");
+- CUtils::PrintError("ZNC will start in 30 seconds.");
+- sleep(30);
+- }
-
- if (bMakeConf) {
- if (!pZNC->WriteNewConfig(sConfig)) {
- CZNC::DestroyInstance();
-@@ -346,6 +333,20 @@ int main(int argc, char** argv) {
- return 1;
- }
+ if (bMakeConf) {
+ if (!pZNC->WriteNewConfig(sConfig)) {
+ CZNC::DestroyInstance();
+@@ -460,6 +443,23 @@ int main(int argc, char** argv) {
+ return 1;
+ }
-+ if (isRoot()) {
-+ CUtils::PrintError("You are running ZNC as root! Don't do that! There are not many valid");
-+ CUtils::PrintError("reasons for this and it can, in theory, cause great damage!");
-+ if (!bAllowRoot) {
-+ CZNC::DestroyInstance();
-+ return 1;
-+ }
-+ CUtils::PrintError("You have been warned.");
-+ CUtils::PrintError("Hit CTRL+C now if you don't want to run ZNC as root.");
-+ CUtils::PrintError("ZNC will start in 30 seconds.");
-+ sleep(30);
-+ }
++ if (isRoot()) {
++ CUtils::PrintError(
++ "You are running ZNC as root! Don't do that! There are not many "
++ "valid");
++ CUtils::PrintError(
++ "reasons for this and it can, in theory, cause great damage!");
++ if (!bAllowRoot) {
++ CZNC::DestroyInstance();
++ return 1;
++ }
++ CUtils::PrintError("You have been warned.");
++ CUtils::PrintError(
++ "Hit CTRL+C now if you don't want to run ZNC as root.");
++ CUtils::PrintError("ZNC will start in 30 seconds.");
++ sleep(30);
++ }
+
-+
- if (bForeground) {
- int iPid = getpid();
- CUtils::PrintMessage("Staying open for debugging [pid: " + CString(iPid) + "]");
+ if (bForeground) {
+ int iPid = getpid();
+ CUtils::PrintMessage("Staying open for debugging [pid: " +
diff --git a/net/znc/patches/101-Reduce_rebuild_time.patch b/net/znc/patches/101-Reduce_rebuild_time.patch
index 60d335c74..6282482f0 100644
--- a/net/znc/patches/101-Reduce_rebuild_time.patch
+++ b/net/znc/patches/101-Reduce_rebuild_time.patch
@@ -11,7 +11,7 @@ Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp
--- a/Makefile.in
+++ b/Makefile.in
-@@ -112,7 +112,7 @@ clean:
+@@ -128,7 +128,7 @@ clean:
distclean: clean
rm -rf $(DISTCLEAN)
@@ -22,7 +22,7 @@ Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp
$(Q)$(CXX) $(CXXFLAGS) -c -o $@ $< -MD -MF .depend/$*.dep -MT $@
--- a/modules/Makefile.in
+++ b/modules/Makefile.in
-@@ -112,12 +112,12 @@ install_datadir:
+@@ -127,12 +127,12 @@ install_datadir:
clean:
rm -rf $(CLEAN)
diff --git a/net/znc/patches/104-disable-empty-modules-check.patch b/net/znc/patches/104-disable-empty-modules-check.patch
index d92deeea3..6395af591 100644
--- a/net/znc/patches/104-disable-empty-modules-check.patch
+++ b/net/znc/patches/104-disable-empty-modules-check.patch
@@ -1,15 +1,17 @@
--- a/src/main.cpp
+++ b/src/main.cpp
-@@ -304,10 +304,12 @@ int main(int argc, char** argv) {
- CUtils::PrintStatus(false, "");
- CUtils::PrintError("No modules found. Perhaps you didn't install ZNC properly?");
- CUtils::PrintError("Read http://wiki.znc.in/Installation for instructions.");
+@@ -412,12 +412,14 @@ int main(int argc, char** argv) {
+ "No modules found. Perhaps you didn't install ZNC properly?");
+ CUtils::PrintError(
+ "Read https://wiki.znc.in/Installation for instructions.");
+#if 0
- if (!CUtils::GetBoolInput("Do you really want to run ZNC without any modules?", false)) {
- CZNC::DestroyInstance();
- return 1;
- }
+ if (!CUtils::GetBoolInput(
+ "Do you really want to run ZNC without any modules?",
+ false)) {
+ CZNC::DestroyInstance();
+ return 1;
+ }
+#endif
- }
- CUtils::PrintStatus(true, "");
- }
+ }
+ CUtils::PrintStatus(true, "");
+ }