aboutsummaryrefslogtreecommitdiff
path: root/net/zerotier
diff options
context:
space:
mode:
authorMoritz Warning <moritzwarning@web.de>2017-01-08 23:14:07 +0100
committerMoritz Warning <moritzwarning@web.de>2017-01-08 23:15:03 +0100
commit6addfe52ea3b8ddd3ed294b60df609c42e5e9358 (patch)
tree7d0eb3dc0692282f95e58b145c2afc1b3aa96730 /net/zerotier
parent3b73eb19b05ac6c0b75a1ddb6f70a5a8d0c92b2f (diff)
net/zerotier: fix broken dependency detection
Signed-off-by: Moritz Warning <moritzwarning@web.de>
Diffstat (limited to 'net/zerotier')
-rw-r--r--net/zerotier/patches/0002-fix-build.patch51
1 files changed, 33 insertions, 18 deletions
diff --git a/net/zerotier/patches/0002-fix-build.patch b/net/zerotier/patches/0002-fix-build.patch
index 8ca9bc8d6..34088c8c5 100644
--- a/net/zerotier/patches/0002-fix-build.patch
+++ b/net/zerotier/patches/0002-fix-build.patch
@@ -7,30 +7,45 @@ Subject: [PATCH 2/2] fix build
make-linux.mk | 30 +++++++++++++++---------------
1 file changed, 15 insertions(+), 15 deletions(-)
-Index: ZeroTierOne-1.1.14/make-linux.mk
-===================================================================
---- ZeroTierOne-1.1.14.orig/make-linux.mk
-+++ ZeroTierOne-1.1.14/make-linux.mk
-@@ -39,19 +39,19 @@ include objects.mk
+--- a/make-linux.mk
++++ b/make-linux.mk
+@@ -39,24 +39,24 @@ include objects.mk
# On Linux we auto-detect the presence of some libraries and if present we
# link against the system version. This works with our package build images.
-ifeq ($(wildcard /usr/include/lz4.h),)
-+ifeq ($(wildcard $(STAGING_DIR)/usr/include/lz4.h),)
++#ifeq ($(wildcard $(STAGING_DIR)/usr/include/lz4.h),)
OBJS+=ext/lz4/lz4.o
- else
- LDLIBS+=-llz4
- DEFS+=-DZT_USE_SYSTEM_LZ4
- endif
+-else
+- LDLIBS+=-llz4
+- DEFS+=-DZT_USE_SYSTEM_LZ4
+-endif
-ifeq ($(wildcard /usr/include/http_parser.h),)
-+ifeq ($(wildcard $(STAGING_DIR)/usr/include/http_parser.h),)
++#else
++# LDLIBS+=-llz4
++# DEFS+=-DZT_USE_SYSTEM_LZ4
++#endif
++#ifeq ($(wildcard $(STAGING_DIR)/usr/include/http_parser.h),)
OBJS+=ext/http-parser/http_parser.o
- else
- LDLIBS+=-lhttp_parser
- DEFS+=-DZT_USE_SYSTEM_HTTP_PARSER
- endif
+-else
+- LDLIBS+=-lhttp_parser
+- DEFS+=-DZT_USE_SYSTEM_HTTP_PARSER
+-endif
-ifeq ($(wildcard /usr/include/json-parser/json.h),)
-+ifeq ($(wildcard $(STAGING_DIR)/usr/include/json-parser/json.h),)
++#else
++# LDLIBS+=-lhttp_parser
++# DEFS+=-DZT_USE_SYSTEM_HTTP_PARSER
++#endif
++#ifeq ($(wildcard $(STAGING_DIR)/usr/include/json-parser/json.h),)
OBJS+=ext/json-parser/json.o
- else
- LDLIBS+=-ljsonparser
+-else
+- LDLIBS+=-ljsonparser
+- DEFS+=-DZT_USE_SYSTEM_JSON_PARSER
+-endif
++#else
++# LDLIBS+=-ljsonparser
++# DEFS+=-DZT_USE_SYSTEM_JSON_PARSER
++#endif
+
+ ifeq ($(ZT_USE_MINIUPNPC),1)
+ OBJS+=osdep/PortMapper.o