aboutsummaryrefslogtreecommitdiff
path: root/net/xray-core/Makefile
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2022-06-21 01:27:59 +0800
committerRosen Penev <rosenp@gmail.com>2022-06-20 17:44:45 -0600
commitc6103fe402822e91050b427fcb981e725e681f45 (patch)
tree1dcb4f5873180e6e0b8c699855254fe6e5eea403 /net/xray-core/Makefile
parentb9a47cc470b19346049d394d4992f5ebdada0702 (diff)
xray-core: Update to 1.5.8
Updated geodata to latest version while at it. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'net/xray-core/Makefile')
-rw-r--r--net/xray-core/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/net/xray-core/Makefile b/net/xray-core/Makefile
index 8c3de96b2..030414e08 100644
--- a/net/xray-core/Makefile
+++ b/net/xray-core/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=xray-core
-PKG_VERSION:=1.5.7
+PKG_VERSION:=1.5.8
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/XTLS/Xray-core/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=6e1761b63da7fb17da98aa6cf74d224882467cd9825c12eb0ab28eacf8d92d19
+PKG_HASH:=1d1f7f3de0596c430fde6e3027b93c45f5fa340d291c05bc48216750dc77ca8f
PKG_MAINTAINER:=Tianling Shen <cnsztl@immortalwrt.org>
PKG_LICENSE:=MPL-2.0
@@ -78,22 +78,22 @@ define Package/xray-core/conffiles
/etc/config/xray
endef
-GEOIP_VER:=202205260055
+GEOIP_VER:=202206160052
GEOIP_FILE:=geoip.dat.$(GEOIP_VER)
define Download/geoip
URL:=https://github.com/v2fly/geoip/releases/download/$(GEOIP_VER)/
URL_FILE:=geoip.dat
FILE:=$(GEOIP_FILE)
- HASH:=c9eb7a4897a7bdafad5d4a71f966345674bd7f3f8ab487cb05599ed17b325106
+ HASH:=35b18994e541e5c3e3d64a39af0d2f81f7d88cc7c87bfba5ea5f20a51390a4c6
endef
-GEOSITE_VER:=20220528180904
+GEOSITE_VER:=20220620091914
GEOSITE_FILE:=dlc.dat.$(GEOSITE_VER)
define Download/geosite
URL:=https://github.com/v2fly/domain-list-community/releases/download/$(GEOSITE_VER)/
URL_FILE:=dlc.dat
FILE:=$(GEOSITE_FILE)
- HASH:=d0c9f3cbf7925c33dfb8fb9578cdfa6733fc9f19c2ccfb4cba5a6415a14afe5c
+ HASH:=10555c5a6de954b362bbaf6059a61209bbebc920e67650d6eef184bb846516f5
endef
define Build/Prepare