aboutsummaryrefslogtreecommitdiff
path: root/net/xray-core/Makefile
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2021-10-28 17:13:38 +0800
committerRosen Penev <rosenp@gmail.com>2021-10-30 01:06:40 -0700
commitab540e6990a26950a8bee31ae306928f573f0874 (patch)
tree8a3e43dc91db5651d345fc65973fabdb1eccc50f /net/xray-core/Makefile
parent17e416bf31cd3990f5a780ec5244403113ebcc60 (diff)
xray-core: remove dead jail files
It never works... And Xray-core needs root access to work. Bump geodata to latest version while at it. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'net/xray-core/Makefile')
-rw-r--r--net/xray-core/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/net/xray-core/Makefile b/net/xray-core/Makefile
index 12655e9e9..c5d8a6045 100644
--- a/net/xray-core/Makefile
+++ b/net/xray-core/Makefile
@@ -78,24 +78,24 @@ define Package/xray-core/conffiles
/etc/config/xray
endef
-GEOIP_VER:=202109060310
+GEOIP_VER:=202110210032
GEOIP_FILE:=geoip.dat.$(GEOIP_VER)
define Download/geoip
URL:=https://github.com/v2fly/geoip/releases/download/$(GEOIP_VER)/
URL_FILE:=geoip.dat
FILE:=$(GEOIP_FILE)
- HASH:=ed94122961f358abede9f1954722039d5a0300b614c77cc27d92618c08b97bb8
+ HASH:=932cd484471f8066c040ab84a04fdd70df6c5cee99545de610e1f337bb696220
endef
-GEOSITE_VER:=20210906031055
+GEOSITE_VER:=20211018134657
GEOSITE_FILE:=dlc.dat.$(GEOSITE_VER)
define Download/geosite
URL:=https://github.com/v2fly/domain-list-community/releases/download/$(GEOSITE_VER)/
URL_FILE:=dlc.dat
FILE:=$(GEOSITE_FILE)
- HASH:=7618b876fd5a1066d0b44c1c8ce04608495ae991806890f8b1cbfafe79caf6c1
+ HASH:=60b2388b11f1f9b6e14794fbacdf3bf693e3101e3ec651ce5423d8caceda5497
endef
define Build/Prepare
@@ -118,9 +118,6 @@ define Package/xray-core/install
$(INSTALL_CONF) $(CURDIR)/files/xray.conf $(1)/etc/config/xray
$(INSTALL_DIR) $(1)/etc/init.d/
$(INSTALL_BIN) $(CURDIR)/files/xray.init $(1)/etc/init.d/xray
-
- $(INSTALL_DIR) $(1)/etc/capabilities/
- $(INSTALL_DATA) $(CURDIR)/files/xray.capabilities $(1)/etc/capabilities/xray.json
endef
define Package/xray-example/install