aboutsummaryrefslogtreecommitdiff
path: root/net/xray-core/Makefile
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2021-09-02 05:31:15 +0800
committerJeffery To <jeffery.to@gmail.com>2021-09-02 05:31:15 +0800
commit8a6def501a90cbe4af9ecda867c4872b02470515 (patch)
tree95529bb4d8ac802ad9257e6a6d1d0bbffff2bdff /net/xray-core/Makefile
parent1f132a184b60b3fc5e263a88d4b6559cd3adf819 (diff)
treewide: Remove GO_PKG_LDFLAGS for stripping binaries
The "-s -w" flags in GO_PKG_LDFLAGS tells the Go compiler to strip the binaries it produces. Since the default Go package build process will strip binaries when CONFIG_USE_STRIP or CONFIG_USE_SSTRIP are selected, these flags are unnecessary. When CONFIG_NO_STRIP is selected, these flags override the user's intention of building unstripped packages. This removes these flags for all relevant packages. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'net/xray-core/Makefile')
-rw-r--r--net/xray-core/Makefile1
1 files changed, 0 insertions, 1 deletions
diff --git a/net/xray-core/Makefile b/net/xray-core/Makefile
index cf1018ab5..91b7198a1 100644
--- a/net/xray-core/Makefile
+++ b/net/xray-core/Makefile
@@ -19,7 +19,6 @@ PKG_USE_MIPS16:=0
GO_PKG:=github.com/xtls/xray-core
GO_PKG_BUILD_PKG:=github.com/xtls/xray-core/main
-GO_PKG_LDFLAGS:=-s -w
GO_PKG_LDFLAGS_X:= \
$(GO_PKG)/core.build=OpenWrt \
$(GO_PKG)/core.version=$(PKG_VERSION)